axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Peterson (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-1319) Redeployment of service with '.' in aar name fails
Date Tue, 10 Oct 2006 17:12:20 GMT
    [ http://issues.apache.org/jira/browse/AXIS2-1319?page=comments#action_12441209 ] 
            
Jeff Peterson commented on AXIS2-1319:
--------------------------------------

I need to try and reproduce this issue in a clean environment.  There were a lot of things
going wrong with that app server when I reported the bug.

> Redeployment of service with '.' in aar name fails
> --------------------------------------------------
>
>                 Key: AXIS2-1319
>                 URL: http://issues.apache.org/jira/browse/AXIS2-1319
>             Project: Apache Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: deployment
>    Affects Versions: 1.0
>            Reporter: Jeff Peterson
>
> There seems to be a problem with service archives having names like "service-2.0.aar".
 I presume its an issue with the additional "." in the archive name not being handled correctly.
 It seems that the service group name is being set to "service-2" instead of "service-2.0".
> My services.xml looks like the following:
> <serviceGroup>
>   <service name="TestWebService">
>     <!-- ... -->
>   </service>
> </serviceGroup>
> Here's what I did and the accompanying error message:
> 1. Deploy service "service-1.0.aar" by dropping it in the "axis2/WEB-INF/services" directory
> 2. Make change to service, and repackage.
> 3. Redeploy service "service-1.0.aar" by dropping it in the "axis2/WEB-INF/services"
directory
> 4. Notice the following errors in server log
> ...
> 06 Oct 2006 16:52:34,330 DEBUG ProjectResourceBundle []: org.apache.axis2.i18n.resource::handleGetObject(invalidservicegroupname)
> 06 Oct 2006 16:52:34,330 DEBUG ProjectResourceBundle []: org.apache.axis2.i18n.resource::handleGetObject(invalidservicegroupname)
> 06 Oct 2006 16:52:34,331 INFO  DeploymentEngine []: org.apache.axis2.AxisFault: invalid
service group name : service-2
> 06 Oct 2006 16:52:34,331 INFO  DeploymentEngine []: org.apache.axis2.AxisFault: invalid
service group name : service-2
> 06 Oct 2006 17:02:17,944 DEBUG ProjectResourceBundle []: org.apache.axis2.i18n.resource::handleGetObject(twoservicecannothavesamename)
> 06 Oct 2006 17:02:17,945 ERROR DeploymentEngine []: Invalid service  service-2.0.aar
due to Two services can not have same name, a service with TestWebService already exists in
the system org.apache.axis2.AxisFault: Two services can not have same name, a service with
TestWebService already exists in the system
>         at org.apache.axis2.engine.AxisConfiguration.addServiceGroup(AxisConfigu
> ration.java:198)
>         at org.apache.axis2.deployment.DeploymentEngine.addServiceGroup(Deployme
> ntEngine.java:438)
> e.java:624)
>         at org.apache.axis2.deployment.repository.util.WSInfoList.update(WSInfoL
> ist.java:195)
>         at org.apache.axis2.deployment.RepositoryListener.update(RepositoryListe
> ner.java:207)
> ...

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message