axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "vikas charak (JIRA)" <j...@apache.org>
Subject [jira] Created: (AXIS2-1193) Response not matching with part name
Date Tue, 19 Sep 2006 17:01:22 GMT
Response not matching with part name 
-------------------------------------

                 Key: AXIS2-1193
                 URL: http://issues.apache.org/jira/browse/AXIS2-1193
             Project: Apache Axis 2.0 (Axis2)
          Issue Type: Bug
          Components: core
         Environment: OS: Windows XP
Server: Jboss4.0.4 GA
Axis2 nightly of Sep-18-2006
            Reporter: vikas charak


My
WSDL as displayed by Axis2 in the web page has the following message
 <wsdl:message name="getCodeResponse"> <wsdl:part name="getCodeReturn" element="impl:getCodeReturn"/>
</wsdl:message>


When the service is invoked I get the following response.

<?xml version='1.0' encoding='UTF-8'?>
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"> <soapenv:Header
/>
<soapenv:Body>

<ns:getCodeResponse xmlns:ns="http://SimpleService.webservices.wammis.com"> 
<ns:return>Service Invocation was successful </ns:return>

</ns:getCodeResponse> 
</soapenv:Body>
</soapenv:Envelope>


Why I do not see element name "getCodeReturn" anywhere in the response? Instead of <return>
probably it should be part name <getCodeReturn>.



-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message