axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Deepal Jayasinghe (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-682) Problems testing Axis2 1.0 with Oracle OC4J (9.0.4)
Date Wed, 30 Aug 2006 11:12:23 GMT
    [ http://issues.apache.org/jira/browse/AXIS2-682?page=comments#action_12431538 ] 
            
Deepal Jayasinghe commented on AXIS2-682:
-----------------------------------------

I think we can resolve the issue since all the issued are fixed now 

what do you think dims ?

> Problems testing Axis2 1.0 with Oracle OC4J (9.0.4)
> ---------------------------------------------------
>
>                 Key: AXIS2-682
>                 URL: http://issues.apache.org/jira/browse/AXIS2-682
>             Project: Apache Axis 2.0 (Axis2)
>          Issue Type: Bug
>            Reporter: Davanum Srinivas
>         Assigned To: Deepal Jayasinghe
>
> Hello,
> I copied the content of axis2.war into a web application and run it from
> the OC4J container (9.0.4) from JDeveloper 9.0.5.2.
> I noticed the following problems:
> 1. Because we have an 'error.jsp' file and an 'Error' subdirectory in
> the axis2-web directory, the jsp compiler reports an error:
> Error: package and class have same name: _axis2_2d_web._error
> Resolution: rename the directory 'Error' to 'Errors' and change the
> error-page urls in the web.xml accordingly.
> 2. When I click on the 'Services' link on the Welcome page,  the
> contenttype of the result page is text/plain instead of text/html, so I
> get the page source in Firefox. The same behavior in all pages that are
> generated using the request.getRequestDispatcher(jspname).include().
> Putting the following line before the dispatching in the renderView
> method of the AbstractAgent class resolves the problem:
> httpServletResponse.setContentType("text/html;charset=UTF-8");
> 3. Getting the wsdl of the 'version' service on the service list page
> (url: context-root/services/version?wsdl) displays an error:
> Requested resource not found!
> This is because the line 87 in ListingAgent does not detect the wsdl
> request parameter:
> httpServletRequest.getParameter("wsdl") returns null in OC4J
> (request.getParameterNames() returns an empty enumeration).
> Calling with context-root/services/version?wsdl=x will return the wsdl.
> I have never used jsp with OC4J before (we use Velocity), so I think the
> OC4J gurus can comment these issues and hopefully can find better solutions.
> One more strange code fragment in RPCMessageReceiver.java (around line 114):
>            // Handling the response
>            AxisMessage outaxisMessage =
> op.getMessage(WSDLConstants.MESSAGE_LABEL_OUT_VALUE);
>            if (inaxisMessage != null) {
>                messageNameSpace =
> outaxisMessage.getElementQName().getNamespaceURI();
>            }
> instead of checking  inaxisMessage != null probably we should check
> outaxisMessage != null. I think the problem is the result of copy/pasting.
> Regards,
> Laszlo

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message