axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Siegfried Sauter-Fischer (JIRA)" <axis-...@ws.apache.org>
Subject [jira] Created: (AXIS-2544) wsdl2java fails to create array like objects containing attributes
Date Fri, 18 Aug 2006 08:26:15 GMT
wsdl2java fails to create array like objects containing attributes
------------------------------------------------------------------

                 Key: AXIS-2544
                 URL: http://issues.apache.org/jira/browse/AXIS-2544
             Project: Apache Axis
          Issue Type: Bug
          Components: Basic Architecture
    Affects Versions: 1.3, 1.4
         Environment: Windows 2000 professional.

java version "1.4.2_05"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_05-b04)
Java HotSpot(TM) Client VM (build 1.4.2_05-b04, mixed mode)

            Reporter: Siegfried Sauter-Fischer


I tried to create dataobjects using the following WSDL

<?xml version="1.0" encoding="UTF-8"?>
<wsdl:definitions
 targetNamespace="http://axis-test.t-mobile.de/test/attribute"
 xmlns:attribute="http://axis-test.t-mobile.de/test/attribute"
 xmlns:xsd="http://www.w3.org/2001/XMLSchema"
 xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/">
 <wsdl:types>
  <schema xmlns="http://www.w3.org/2001/XMLSchema">
   <import namespace="http://schemas.xmlsoap.org/soap/encoding/"/>
   <complexType name="ArrayAndAttributeBeanUser">
      <sequence>
       <element name="arrayAndAttributeBeanInstance" type="attribute:ArrayAndAttributeBean"/>
      </sequence>
   </complexType>
   <complexType name="ArrayAndAttributeBean">
    <sequence>
     <element name="baseContent" maxOccurs="unbounded" minOccurs="0" type="xsd:string"/>
    </sequence>
    <attribute name="myAttribute" type="xsd:string"/>
   </complexType>
  </schema>
 </wsdl:types>
</wsdl:definitions>

As a result I got a single java class named ArrayAndAttributeBeanUser, containing a String
array named arrayAndAttributeBeanInstance.

Without the line
    <attribute name="myAttribute" type="xsd:string"/>
this would be the right behavior, as it would be recomend to look arrayAndAttributeBeanInstance
as to BE an array, not to CONTAIN an array.
But as an array has no attribute, the attribute "myAttribute" is simply missing. Therefore
it is recomendet to look arrayAndAttributeBeanInstance as an Bean containing an array and
a simple type for the attribute.

Adding an element, not an attribute, the behavior is as expected.


-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message