axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William Ferguson (JIRA)" <j...@apache.org>
Subject [jira] Created: (AXIS2-1067) Consistent naming for the message and operation elements generated by Java2WSDL
Date Thu, 24 Aug 2006 20:14:31 GMT
Consistent naming for the message and operation elements generated by Java2WSDL
-------------------------------------------------------------------------------

                 Key: AXIS2-1067
                 URL: http://issues.apache.org/jira/browse/AXIS2-1067
             Project: Apache Axis 2.0 (Axis2)
          Issue Type: Improvement
          Components: wsdl
    Affects Versions: 1.0
            Reporter: William Ferguson


For a service method 'getSomeValue' that accepts and returns a String, Java2WSDL will generate
2 wsdl types, 2 message elements and an operation element of the form:
	<xs:element name="getSomeValue">
		<xs:complexType>
			<xs:sequence>
				<xs:element type="xs:String" name="someParam"/>
			</xs:sequence>
		</xs:complexType>
	</xs:element>
	<xs:element name="getSomeValueResponse">
		<xs:complexType>
			<xs:sequence>
				<xs:element type="xs:String" name="return"/>
			</xs:sequence>
		</xs:complexType>
	</xs:element>

	<wsdl:message name="getSomeValueMessage">
		<wsdl:part element="ns0:getSomeValue" name="part1"/>
	</wsdl:message>
	<wsdl:message name="getSomeValueResponse">
		<wsdl:part element="ns0:getSomeValueResponse" name="part1"/>
	</wsdl:message>

	<wsdl:operation name="getSomeValue">
		<wsdl:input message="axis2:getSomeValueMessage"/>
		<wsdl:output message="axis2:getSomeValueResponse"/>
	</wsdl:operation>

It seems to me that it would be clearer to use the Request/Response naming convention for
all 3.
Ie the wsdl types defined as
	<xs:element name="<methodName>Request">
	<xs:element name="<methodName>Response">
The messages as:
	<wsdl:message name="<methodName>RequestMessage">
		<wsdl:part element="ns0:getSomeValueRequest" name="part1"/>
	</wsdl:message>
	<wsdl:message name="<methodName>ResponseMessage">
		<wsdl:part element="ns0:getSomeValueResponse" name="part1"/>
	</wsdl:message>
And the operation as:
	<wsdl:operation name="getSomeValue">
		<wsdl:input message="axis2:<methodName>RequestMessage"/>
		<wsdl:output message="axis2:<methodName>ResponseMessage"/>
	</wsdl:operation>

It would help differentiate the values within the WSDL and would definitely clarify things
within client that use stubs and data bindings generated from the WSDL.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message