axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fabian Christ (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-1003) No proper databinding when generating with -d xmlbean
Date Thu, 10 Aug 2006 13:08:16 GMT
    [ http://issues.apache.org/jira/browse/AXIS2-1003?page=comments#action_12427205 ] 
            
Fabian Christ commented on AXIS2-1003:
--------------------------------------

Oh thank you. Sorry for that. I should have seen that little "s".

But then please change the error message for this. I didnĀ“t understand from "No proper databinding
has taken place" what Axis tried to tell me.

thanks,
Fabian

> No proper databinding when generating with -d xmlbean
> -----------------------------------------------------
>
>                 Key: AXIS2-1003
>                 URL: http://issues.apache.org/jira/browse/AXIS2-1003
>             Project: Apache Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: wsdl
>            Reporter: Fabian Christ
>         Attachments: sample-wsdl.zip
>
>
> Hi,
> when I try to generate the java files with WSDL2Java with options "-sd -ss -d xmlbean"
I get the following exception
> Exception in thread "main" org.apache.axis2.wsdl.codegen.CodeGenerationException: org.apache.axis2.wsdl.codegen.CodeGenerationException:
No proper databinding has taken place
> 	at org.apache.axis2.wsdl.codegen.CodeGenerationEngine.generate(CodeGenerationEngine.java:224)
> 	at org.apache.axis2.wsdl.WSDL2Code.main(WSDL2Code.java:32)
> 	at org.apache.axis2.wsdl.WSDL2Java.main(WSDL2Java.java:21)
> Caused by: org.apache.axis2.wsdl.codegen.CodeGenerationException: No proper databinding
has taken place
> 	at org.apache.axis2.wsdl.codegen.extension.DefaultDatabindingExtension.engage(DefaultDatabindingExtension.java:37)
> 	at org.apache.axis2.wsdl.codegen.CodeGenerationEngine.generate(CodeGenerationEngine.java:177)
> 	... 2 more
> I tried with sources from SVN and with nightly build - the result is the same.
> Any ideas where I should search for this bug? Or what the reason for this is?
> thanks,
> Fabian

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message