axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kent Tong (JIRA)" <>
Subject [jira] Commented: (AXIS2-673) aar file is locked in Tomcat
Date Sun, 30 Jul 2006 11:57:14 GMT
    [ ] 
Kent Tong commented on AXIS2-673:

I just tried it using the nightly build on June 16 and the problem still persists. The .aar
file is locked even for services that had been there when Tomcat was started.

> aar file is locked in Tomcat
> ----------------------------
>                 Key: AXIS2-673
>                 URL:
>             Project: Apache Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: deployment
>    Affects Versions: 1.0
>         Environment: Axis2 1.0 RC4. Tomcat 5.5.7. Win XP.
>            Reporter: Kent Tong
>         Assigned To: Deepal Jayasinghe
> 1) Start Tomcat.
> 2) Put an aar file such as test.aar into webapps/Axis2/WEB-INF/services to hot-deploy
> 3) Try to delete the aar file. It says something to the effect of "file is being used
by another process and can't be deleted".
> It means one can never hot-undeploy a service by deleting the aar file. This issue should
have nothing to do with antiJARLocking as Axis2 is using a ZipInputStream to access the aar
file. In fact, I've even tried setting antiJARLocking to true but the problem persists.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message