axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Deepal Jayasinghe (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-850) NullPointerException in AbstractHTTPSender
Date Mon, 31 Jul 2006 10:46:14 GMT
    [ http://issues.apache.org/jira/browse/AXIS2-850?page=comments#action_12424508 ] 
            
Deepal Jayasinghe commented on AXIS2-850:
-----------------------------------------

I fixed this issue few days ago , can you please check whether error is still there

> NullPointerException in AbstractHTTPSender
> ------------------------------------------
>
>                 Key: AXIS2-850
>                 URL: http://issues.apache.org/jira/browse/AXIS2-850
>             Project: Apache Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: transports
>         Environment: Windows XP SP2, J2SE 1.5.0_03, Axis2 SNAPSHOT Jun 08, 2006
>            Reporter: Michele Mazzucco
>
> I get a NullPointerException in AbstractHTTPSender:238 when the
> following message is received:
> <?xml version='1.0' encoding='utf-8'?>
> <soapenv:Envelope
> xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
> xmlns:wsa="http://www.w3.org/2005/08/addressing">
> 	<soapenv:Header>
> 		<node:qosp xmlns:node="http://org.ncl.ac.uk/qosp">
> 			<node:messageType>
> 				<node:value>Result</node:value>
> 			</node:messageType>
> 			<node:timeInfo>
> 				<node:scheduling>0</node:scheduling>
> 				<node:queue>0</node:queue>
> 				<node:inNetwork>0</node:inNetwork>
> 				<node:codestore>0</node:codestore>
> 				<node:deployment>0</node:deployment>
> 				<node:execution>1151071762667</node:execution>
> 			</node:timeInfo>
> 		</node:qosp>
> 		
> 		<wsa:To>http://localhost:8080/axis2/services/RoutingService</wsa:To>
> 		<wsa:ReplyTo />
> 		<wsa:From>
> 		
> <wsa:Address>http://10.8.149.156:18080/axis2/services/MyService</wsa:Address>
> 		</wsa:From>
> 		<wsa:FaultTo><
> 		
> wsa:Address>http://10.8.149.156:18080/axis2/services/MyService</wsa:Address>
> 		</wsa:FaultTo>
> 		<wsa:MessageID>urn:uuid:B8218EB67E48B4770A11510717626673</wsa:MessageID>
> 		<wsa:Action>urn:result</wsa:Action>
> 		<wsa:RelatesTo
> wsa:RelationshipType="http://www.w3.org/2005/08/addressing/reply">urn:uuid:6C3FF1911E6B2CC78411510717620891</wsa:RelatesTo>
> 	</soapenv:Header>
> 	<soapenv:Body>
> 		<client:echo
> xmlns:client="http://org.ncl.ac.uk/qosp/clients/codestore"
> xmlns:tns="http://ws.apache.org/axis2">
> 			<client:Text>QoSP Echo String</client:Text>
> 		</client:echo>
> 	</soapenv:Body>
> </soapenv:Envelope>
> The reason of null pointer is the RelatesTo. Method 
> void A.first() 
> sends a message to 
> OMElement B.foo(). B.foo() processes the message and replies top A.second() (this is
obtained via handler). When A.second() receives the message (which is actually a response
to the message sent by A.first()), it contains a RelatesTo() element, which causes the problem.
Removing the RelatesTo portion before the message hits the method fix the problem.
> Please note that modifying $CATALINA_HOME\\webapps\axis2\WEB-INF\classes\log4j.properties
didn't allow me to trace the problem to a log file.
> Michele

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message