axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Blunck (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-668) AntCodegenTask throws exception
Date Sun, 11 Jun 2006 21:54:31 GMT
    [ http://issues.apache.org/jira/browse/AXIS2-668?page=comments#action_12415791 ] 

Christopher Blunck commented on AXIS2-668:
------------------------------------------

I found a semi-workable (well, nonoffensive) workaround for Eclipse users.

I removed the jsr173_1.0_api.jar and sjsxp.jar from the endorsed directory of my JDK (/Library/Java/Home/lib/endorsed).
 I then set up a custom builder in Eclipse for my project by performing the following steps:

1.) Right click on your project name in the Navigator, and left click on Properties.
2.) Left click on Builders in the navigation panel on the left.
3.) Uncheck all the existing builders.  Ignore the warning dialog windows Eclipse raises.
4.) Click the "New" button to create a new builder.
5.) Click on the Ant icon to signfiy you want to create a builder based on an Ant file.
6.) Name the builder.  I chose "Axis2 Builder"
7.) In the Buildfile section, click on "Browse Workspace" and navigate to your build.xml
8.) Ignore the Base Directory property.
9.) Click the Refresh tab, and check the "Refresh resources upon completion" checkbox
10.) Click the Classpath tab, click on "User Entries," and click the "Add JARs..." button
on the right.
11.) Navigate to the jsr173_1.0_api.jar and click Choose.  Do the same for sjsxp.jar.
12.) Click ok to create the builder and return to the Builders dialog window.  Make sure your
new builder is selected.
13.) Click ok to dismiss the properties window, and click the Projects->Build menu.

Note: if you don't include the sjsxp.jar and jsr173_1.0_api.jar inside of your project you
will want to click on the "Add External JARs..." button in step #11.

This appears to have the same effect as placing the two StAX related JARs in your endorsed
directory.  When I run the codegen process in Ant via Eclipse the classes are generated properly.
 When I run the codegen process in Ant OUTSIDE of Eclipse I puke with the com.bea.... message.

Hope this gets fixed sometime soon... 


-c 


> AntCodegenTask throws exception
> -------------------------------
>
>          Key: AXIS2-668
>          URL: http://issues.apache.org/jira/browse/AXIS2-668
>      Project: Apache Axis 2.0 (Axis2)
>         Type: Bug

>   Components: Tools
>     Versions: 1.0
>  Environment: axis2-1.0 svn 2005-05-04 (noon)
>     Reporter: Bryan Brouckaert
>     Assignee: Ajith Harshana Ranabahu
>  Attachments: build-test.xml, jars.txt
>
> The AntCodegenTask throws following error: "javax.xml.stream.FactoryConfigurationError:
Provider com.bea.xml.stream.MXParserFactory not found"
> All jars of the Axis2 library are included in the class path.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message