axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Igor Peshansky (JIRA)" <j...@apache.org>
Subject [jira] Created: (AXIS2-792) Populating an AxisService via ServiceBuilder does not set service name
Date Fri, 02 Jun 2006 04:19:29 GMT
Populating an AxisService via ServiceBuilder does not set service name
----------------------------------------------------------------------

         Key: AXIS2-792
         URL: http://issues.apache.org/jira/browse/AXIS2-792
     Project: Apache Axis 2.0 (Axis2)
        Type: Bug

  Components: core  
    Versions: 1.0    
    Reporter: Igor Peshansky


After populating an AxisService using

DeploymentEngine engine = new DeploymentEngine();
AxisService svc = engine.buildService(new AxisService(), new FileInputStream("services.xml"),
Thread.currentThread().getContextClassLoader(), engine.getAxisConfig());

where services.xml contains

<service name="TestService"/>

calling svc.getName() returns null, and svc.getServiceDescription() returns "TestService".

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message