axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Sosnoski <...@sosnoski.com>
Subject Re: [Axis2] JAXBRI data binding
Date Sat, 06 May 2006 03:39:20 GMT
That makes sense. I'd say the only solution is to drop the jaxbri module 
from the build when running on 1.4, and to always use Java 5 for the 
release builds. The code within the codegen module shouldn't have any 
dependency on JAXB, so dropping JAXB from the build on 1.4 shouldn't 
effect anything else.

Of course, this means telling maven to make the JAXB references and the 
jaxbri module optional. I assume there's a way to do this using 
scripting... is there a maven maven available?

  - Dennis

Davanum Srinivas wrote:

> the jar is marked version 49.0 and jdk14 compiler does not like it.
>
> -- dims
>
> On 5/5/06, Dennis Sosnoski <dms@sosnoski.com> wrote:
>
>> What problems have you run into with building under 1.4? JAXB 2.0 itself
>> is strictly Java 5+, so I wouldn't expect any tests and such to run, but
>> the part of the code that falls under the codegen module should be able
>> to be 1.4 compatible.
>>
>>   - Dennis
>>
>> Davanum Srinivas wrote:
>>
>> > Ken,
>> >
>> > Looks like we can't build the JAXBRI data binding under 1.4 :( We need
>> > to figure out how to support builds for 1.4.
>> >
>> > thanks,
>> > dims
>> >
>> > --
>> > Davanum Srinivas : http://wso2.com/blogs/
>> >
>>
>
>
> -- 
> Davanum Srinivas : http://wso2.com/blogs/
>

Mime
View raw message