axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Deepal Jayasinghe (JIRA)" <j...@apache.org>
Subject [jira] Created: (AXIS2-745) AdminAgent.processEditServicePara does not work
Date Wed, 17 May 2006 04:35:06 GMT
 AdminAgent.processEditServicePara does not work
------------------------------------------------

         Key: AXIS2-745
         URL: http://issues.apache.org/jira/browse/AXIS2-745
     Project: Apache Axis 2.0 (Axis2)
        Type: Bug

  Components: deployment  
    Reporter: Deepal Jayasinghe
 Assigned to: Deepal Jayasinghe 


I've got some service data defined in service.xml and I'm attempting to update this service
data at runtime via the Admin console, submitting any change to via the admin form seems to
get rejected.
 
So I took a look at the ServiceParaEdit.jsp and org.apache.axis2.transport.http.AdminAgent.
 
AdminAgent.processEditServicePara expects teh received form to contain a parameter editServicePara,
and it's not there, that's the name of the form (dont know why this check is there).
 
Anyway, patching the jsp form by adding a
 
    <input type="hidden" name="editServicepara" value="" />
 
seems to clear the problem but no a funny old text response gets displayed rather than a refreshed
form.


-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message