axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Deepal Jayasinghe (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (AXIS2-574) NullPointer in XMLBeans Factory.parse() after OMElement.toString()
Date Fri, 21 Apr 2006 08:21:06 GMT
     [ http://issues.apache.org/jira/browse/AXIS2-574?page=all ]
     
Deepal Jayasinghe resolved AXIS2-574:
-------------------------------------

    Fix Version: 1.0
     Resolution: Fixed

I will resolved the issue , but if you are still getting the problem pls re-open the issue

> NullPointer in XMLBeans Factory.parse() after OMElement.toString()
> ------------------------------------------------------------------
>
>          Key: AXIS2-574
>          URL: http://issues.apache.org/jira/browse/AXIS2-574
>      Project: Apache Axis 2.0 (Axis2)
>         Type: Bug

>     Versions: 0.95
>     Reporter: Jens Schumann
>      Fix For: 1.0
>  Attachments: TestApi.aar, axis-574-RC1.tar.gz, axis-574.tar.gz
>
> If I call toString() in my generated InOut Class on msgContext.getEnvelope().getBody().getFirstElement()
before calling XMLBeans#Factory.parse() I get an NullPointer in org.apache.xmlbeans.impl.store.Cur$CurLoadContext.finish().
The NullPointerException seems to be related to sending a SOAP Header and not calling getEnvelipe().build()
before calling tostring()
> For further discussion see
> http://marc.theaimsgroup.com/?l=axis-user&m=114523119514899&w=2
> I will attach an working example shortly.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message