axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eran Chinthaka <chinth...@opensource.lk>
Subject Re: [axis2] test failurs and log4j warnings in modules/Integration; where do log messages go?
Date Mon, 17 Apr 2006 14:26:24 GMT
Hi Jeff,

Can you do this, please. Run "maven clean jar" and send us the whole
output you see. And if there are tests failing, please send us the test
reports as well. I prefer if you can create a JIRA and point to that
from here.

(If you do not know how to find test reports, its like this.
If a test is failing in integration module, got to
integration/target/test-reports. And search for the file(s) which
corresponds to the test failure(s). If
org.apache.axis2.engine.EchoRawXMLTest is failing, then you should see
TEST-org.apache.axis2.engine.EchoRawXMLTest.txt in
integration/target/test-reports )

BTW, I don't have IBM Jdk 1.5 with me. Bill Nagy or some one having IBM
Jdk 1.5, are you all experiencing the same thing ?

-- Chinthaka


Jeff Barrett wrote:
> 
> Hi Chinthaka,
> 
> I've seen the failures with both Maven 1.0.2 and 1.1-beta2.  I also see
> the same failures running the tests individually inside Eclipse v3.1.2.
>  I am running the IBM JDK 1.5.
> 
> I did check the FAQ http://ws.apache.org/axis2/faq.html and didn't see
> anything that looked related to this.
> 
> Thanks,
> Jeff
> 
> IBM Software Group - WebSphere Web Services Development
> Phone: 512-838-4587 or Tie Line 678-4587
> Internet e-mail and Sametime ID: barrettj@us.ibm.com
> 
> 
> *Eran Chinthaka <chinthaka@opensource.lk>*
> 
> 04/14/2006 10:40 AM
> Please respond to
> axis-dev@ws.apache.org
> 
> 
> 	
> To
> 	axis-dev@ws.apache.org
> cc
> 	
> Subject
> 	Re: [axis2] test failurs and log4j warnings in modules/Integration;
> where do log messages go?
> 
> 
> 	
> 
> 
> 
> 
> 
> Hi Jeff,
> 
> I just checked the build and the build was successful.
> 
> I'm on JDK 1.5 (in Ubuntu 5.10). Maven 1.0.2.
> 
> 
> Which version of JDK and maven you have ? Did u check the FAQ ?
> 
> -- Chinthaka
> 
> Jeff Barrett wrote:
>>
>> I am having some failures in the Integration module tests from the code
>> I extracted today (Revision: 393790):
>>     [junit] [ERROR] Test
>> org.apache.axis2.engine.CharactersetEncodingTest FAILED
>>     [junit] [ERROR] Test
>> org.apache.axis2.engine.CommonsHTTPEchoRawXMLTest FAILED
>>     [junit] [ERROR] Test org.apache.axis2.engine.EchoRawXMLMultipleTest
>> FAILED
>>     [junit] [ERROR] Test org.apache.axis2.engine.EchoRawXMLTest FAILED
>>     [junit] [ERROR] Test org.apache.axis2.engine.FaultHandlingTest FAILED
>>     [junit] [ERROR] Test org.apache.axis2.engine.SOAPversionTest FAILED
>>     [junit] [ERROR] Test org.apache.axis2.mtom.EchoRawMTOMFileCacheTest
>> FAILED
>>     [junit] [ERROR] Test org.apache.axis2.rpc.MultirefTest FAILED
>>     [junit] [ERROR] Test org.apache.axis2.rpc.RPCCallTest FAILED
>>
>> While trying to look into why the tests are failing, I noticed that all
>> of the test output files (except
>> TEST-org.apache.axis2.integration.EchoTest.txt) have the following
> message:
>>
>> ------------- Standard Error -----------------
>> log4j:WARN No appenders could be found for logger
>> (org.apache.axiom.om.impl.builder.StAXOMBuilder).
>> log4j:WARN Please initialize the log4j system properly.
>> ------------- ---------------- ---------------
>>
>> My questions are:
>> 1) Where is the output from log.error( ... ) when called from the test
>> cases supposed to go?  I believe I am hitting those calls prior to the
>> asserts failing, but I don't see any output.
>>
>> 2) Is the lack of log ouptut related to the log4j:WARN messages above?
>>
>> 3) Is anyone else seeing the test failures above?
>>
>> Thanks in advance for any insights!
>> Jeff
>>
>> IBM Software Group - WebSphere Web Services Development
>> Phone: 512-838-4587 or Tie Line 678-4587
>> Internet e-mail and Sametime ID: barrettj@us.ibm.com
> 
> 
> 



Mime
View raw message