axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Deepal Jayasinghe (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-574) NullPointer in XMLBeans Factory.parse() after OMElement.toString()
Date Fri, 21 Apr 2006 08:17:07 GMT
    [ http://issues.apache.org/jira/browse/AXIS2-574?page=comments#action_12375511 ] 

Deepal Jayasinghe commented on AXIS2-574:
-----------------------------------------

I did the following steps and was able to resolve the issue pls follow the same steps and
clarify that
 (I was able to regenerate the problem)
1.Generate skeleton using your wsdl
2.Then fill the skeleton
3.Then deploy the service
4.remember I used xbean-2.1.0.jar  

Note : The problem is not there in ADB

> NullPointer in XMLBeans Factory.parse() after OMElement.toString()
> ------------------------------------------------------------------
>
>          Key: AXIS2-574
>          URL: http://issues.apache.org/jira/browse/AXIS2-574
>      Project: Apache Axis 2.0 (Axis2)
>         Type: Bug

>     Versions: 0.95
>     Reporter: Jens Schumann
>  Attachments: axis-574-RC1.tar.gz, axis-574.tar.gz
>
> If I call toString() in my generated InOut Class on msgContext.getEnvelope().getBody().getFirstElement()
before calling XMLBeans#Factory.parse() I get an NullPointer in org.apache.xmlbeans.impl.store.Cur$CurLoadContext.finish().
The NullPointerException seems to be related to sending a SOAP Header and not calling getEnvelipe().build()
before calling tostring()
> For further discussion see
> http://marc.theaimsgroup.com/?l=axis-user&m=114523119514899&w=2
> I will attach an working example shortly.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message