axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davanum Srinivas (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (AXIS2-233) Round3 Doclitparam interop test (with codegen and Databinding) failed
Date Thu, 30 Mar 2006 19:38:27 GMT
     [ http://issues.apache.org/jira/browse/AXIS2-233?page=all ]
     
Davanum Srinivas resolved AXIS2-233:
------------------------------------

    Resolution: Fixed

this scenario was covered in the Indigo interop testing...latest svn should be ok.

thanks,
dims

> Round3 Doclitparam interop test (with codegen and Databinding) failed
> ---------------------------------------------------------------------
>
>          Key: AXIS2-233
>          URL: http://issues.apache.org/jira/browse/AXIS2-233
>      Project: Apache Axis 2.0 (Axis2)
>         Type: Bug
>   Components: wsdl
>     Versions: 0.92
>  Environment: Win xp
>     Reporter: Gayan Asanka
>     Assignee: Thilini Gunawardhana

>
> Out of four operations:
>    echoString                -  failed
>    echoStringArray       - failed
>    echoStruct                -failed
>    echoVoid                  - successful
> only echoVoid was successful.
> WSDL :- http://www.whitemesa.net/wsdl/r3/interoptestdoclitparameters.wsdl
> message sent :-
> POST /interop/r3/doclitparam HTTP/1.1
> User-Agent: Axis/2.0
> SOAPAction: http://soapinterop.org/
> Connection: Keep-Alive
> Host: www.whitemesa.net
> Content-Length: 689
> Content-Type: text/xml;charset=UTF-8
> <?xml version='1.0' encoding='UTF-8'?>
>    <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
>       <soapenv:Header>
>          <wsa:To xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing">http://localhost:8000/interop/r3/doclitparam</wsa:To>
>          <wsa:ReplyTo xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing">
>             <wsa:Address>http://schemas.xmlsoap.org/ws/2004/08/addressing/role/anonymous</wsa:Address>
>          </wsa:ReplyTo>
>          <wsa:MessageID xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing">1127380013628</wsa:MessageID>
>       </soapenv:Header>
>       <soapenv:Body>
>          <echoString xmlns="http://soapinterop.org/xsd">
>             <param0>Gayan Asanka</param0>
>          </echoString>
>       </soapenv:Body>
>    </soapenv:Envelope>
> (I tried without addrssing too)
> Message recieved :- 
> HTTP/1.1 500 Internal Server Error
> Date: Thu, 22 Sep 2005 09:21:38 GMT
> Server: WhiteMesa SOAP Server/3.2
> Content-Type: text/xml; charset="utf-8"
> Content-Length: 348
> Connection: close
> <?xml version="1.0" encoding="UTF-8"?>
>    <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
>       <SOAP-ENV:Body>
>          <SOAP-ENV:Fault>
>             <faultcode xmlns:ns="http://schemas.xmlsoap.org/soap/envelope/">ns:Client</faultcode>
>             <faultstring>Message processing failed.</faultstring>
>             <detail />
>          </SOAP-ENV:Fault>
>       </SOAP-ENV:Body>
>    </SOAP-ENV:Envelope>
> This is a successful request i built some other means where i got a correct response:-
> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
> 	<SOAP-ENV:Body>
> 		<m:echoString xmlns:m="http://soapinterop.org/xsd">
> 			<param0>String</param0>
> 		</m:echoString>
> 	</SOAP-ENV:Body>
> </SOAP-ENV:Envelope>
> response:-
> <?xml version="1.0" encoding="UTF-8"?>
> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
> 	<SOAP-ENV:Body>
> 		<iop:echoStringResponse xmlns:iop="http://soapinterop.org/xsd">
> 			<return>String</return>
> 		</iop:echoStringResponse>
> 	</SOAP-ENV:Body>
> </SOAP-ENV:Envelope>
> Gayan Asanka

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message