axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Davanum Srinivas <dava...@gmail.com>
Subject Re: [Axis2] Problem building from source tree
Date Tue, 07 Feb 2006 01:42:33 GMT
Can you please try switching to Maven 1.1-beta2? I've never seen this
specific problem before. Are u using Sun's JDK? I've tried Sun's
1.4,1.5 and JRockit 1.5 as well.

thanks,
dims

On 2/6/06, Bill Nagy <nagy@watson.ibm.com> wrote:
> Hi,
>
> I'm trying to build from the source tree (I've checked out the tree
> several times today), but aside from the terribly slow dependency
> fetching, when it tries to execute the junit tests on the core module,
> the org.apache.axis2.deployment.SameServiceAddingTest test fails.  The
> following is from the log file:
>
> Testsuite: org.apache.axis2.deployment.SameServiceAddingTest
> Tests run: 1, Failures: 1, Errors: 0, Time elapsed: 0.734 sec
>
> ------------- Standard Output ---------------
> - conf directory not found , and no axis2.xml file is given ! System
> will continue using default_axis2.xml
> - Invalid service  .svn due to Invalid service META-INF directory not
> found; nested exception is:
>         org.apache.axis2.deployment.DeploymentException: Invalid service
> META-INF directory not found
> - Error in schema generating :null
> - Error in schema generating :null
> - Error in schema generating :null
> - Error in schema generating :null
> - Invalid service  service1 due to Two services can not have same name,
> a service with serevice1 already exists in the system
> ------------- ---------------- ---------------
> Testcase: testServiceGroup
> (org.apache.axis2.deployment.SameServiceAddingTest):
> FAILED
> null
> junit.framework.AssertionFailedError
>         at
> org.apache.axis2.deployment.SameServiceAddingTest.testServiceGroup
> (SameServiceAddingTest.java:41)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at sun.reflect.NativeMethodAccessorImpl.invoke
> (NativeMethodAccessorImpl.java:64)
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke
> (DelegatingMethodAccessorImpl.java:43)
>
>
> Other than the Assertion failure, does the rest look normal?  I'm on
> Linux running maven 1.0.2 and I've tried both 1.4 and 1.5 JDKs always
> with the same outcome.  Thanks.
>
> -Bill
> nagy@watson.ibm.com
>
>


--
Davanum Srinivas : http://wso2.com/blogs/

Mime
View raw message