axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sanjiva Weerawarana <sanj...@opensource.lk>
Subject Re: [Axis2] -- Problem building ver 0.94
Date Wed, 08 Feb 2006 02:43:29 GMT
Hi Samuel,

I finally understood the problem yesterday .. when we shipped 0.94, it
depended on a version of policy called 0.94-SNAPSHOT. Snapshots are
dynamically downloaded by maven when you build.

However, we recently refactored the policy stuff out of Axis2 into its
own commons project and renamed the version of that to 1.0-SNAPSHOT.

Now when maven looks for 0.94-SNAPSHOT its missing :(.

So in effect the 0.94 src dist is no longer buildable. This is why its
considered VERY bad practice to ship a *src* release with snapshots!!!! 

So Samuel, is it possible for you to drop the 0.94 src dist and just
check out the latest repo? That should build just fine.

Folks, can we PLEASE stop putting version numbers in snapshots? To me
that's SUCH an incredibly bad idea .. a snapshot is just that, a
snapshot and you have no idea what it is .. its whatever happened to be
in the repo at the time you built. When it comes to 1.0 there's no way
we'll ship with any snapshots .. 

Sanjiva.

On Tue, 2006-02-07 at 20:31 -0600, Samuel Isokpunwu wrote:
> 
> Was able to resolve the SNAPSHOT dependency problem by editing the
> project.propertiesand prefixing SNAPSHOT with "1.0-" for
> "ws_policy.version" and "xmlschema.version" and also modified the
> "artifactId"s for "ws-common" groupId in project.xml within the
> core,webapp,codegen,wsdl,addressing, and adb sub-directories from
>  "ws-policy" to "policy" . 
> 
> But have the following compile problems -- 
> 
>     [javac] Compiling 144 source files to D:\dev\axis2\src\modules
> \core\target\classes 
>     [javac] D:\dev\axis2\src\modules\core\src\org\apache\axis2
> \deployment\DescriptionBuilder.java:41 
> 0: cannot access org.apache.ws.commons.om.OMElement 
>     [javac] file org\apache\ws\commons\om\OMElement.class not found 
>     [javac]             Policy p = reader.readPolicy((OMElement)
> policyElements.next()); 
>     [javac]                              ^ 
>     [javac] D:\dev\axis2\src\modules\core\src\org\apache\axis2
> \deployment\DescriptionBuilder.java:42 
> 2: readPolicyReference(org.apache.ws.commons.om.OMElement) in
> org.apache.ws.policy.util.OMPolicyRead 
> er cannot be applied to (org.apache.axis2.om.OMElement) 
>     [javac]                     .readPolicyReference((OMElement)
> policyRefElements.next()); 
>     [javac]                     ^ 
>     [javac] Note: D:\dev\axis2\src\modules\core\src\org\apache\axis2
> \transport\jms\JMSURLHelper.java 
>  uses or overrides a deprecated API. 
>     [javac] Note: Recompile with -Xlint:deprecation for details. 
>     [javac] Note: Some input files use unchecked or unsafe
> operations. 
>     [javac] Note: Recompile with -Xlint:unchecked for details. 
>     [javac] 2 errors 
> 
> I tried to resolve the class not found problem by making
> "axiom-1.0-SNAPSHOT.jar" visible to the build part but then have the
> following compile problems. 
> 
>     [javac] Compiling 144 source files to D:\dev\axis2\src\modules
> \core\target\classes 
>     [javac] D:\dev\axis2\src\modules\core\src\org\apache\axis2
> \deployment\DescriptionBuilder.java:41 
> 0: cannot find symbol 
>     [javac] symbol  : method
> readPolicy(org.apache.axis2.om.OMElement) 
>     [javac] location: class org.apache.ws.policy.util.OMPolicyReader 
>     [javac]             Policy p = reader.readPolicy((OMElement)
> policyElements.next()); 
>     [javac]                              ^ 
>     [javac] D:\dev\axis2\src\modules\core\src\org\apache\axis2
> \deployment\DescriptionBuilder.java:42 
> 2: readPolicyReference(org.apache.ws.commons.om.OMElement) in
> org.apache.ws.policy.util.OMPolicyRead 
> er cannot be applied to (org.apache.axis2.om.OMElement) 
>     [javac]                     .readPolicyReference((OMElement)
> policyRefElements.next()); 
>     [javac]                     ^ 
>     [javac] Note: D:\dev\axis2\src\modules\core\src\org\apache\axis2
> \transport\jms\JMSURLHelper.java 
>  uses or overrides a deprecated API. 
>     [javac] Note: Recompile with -Xlint:deprecation for details. 
>     [javac] Note: Some input files use unchecked or unsafe
> operations. 
>     [javac] Note: Recompile with -Xlint:unchecked for details. 
>     [javac] 2 errors
> 
> Any suggestion? 
> 
> 
> Samuel...............Have  a great day.
> 
> IBM WebSphere Development ("Web Services Engine") {
>      phone = "(512) 838-4963, T/L : 678-4963";
>      internet  = "soi@us.ibm.com";
> } 
> 
> 
> Eran Chinthaka
> <chinthaka@opensource.lk> 
> 
> 02/06/2006 08:34 PM 
>          Please respond to
>       axis-dev@ws.apache.org
> 
> 
> 
> 
>                To
> axis-dev@ws.apache.org 
>                cc
> 
>           Subject
> Re: [Axis2] --
> Problem building
> ver 0.94
> 
> 
> 
> 
> 
> 
> 
> 
> I think the problem is that we renamed tthe SNAPSHOT jars to contain
> 1.0 as well.
> 
> We can either put the old SNAPSHOT jar without 1.0 or please go an
> edit the project.properties file. That contains the versions of all
> the dependencies of Axis2.
> 
> -- Chinthaka
> 
> Samuel Isokpunwu wrote:  
> Thanks. Not sure what build file(s) to modify to make these jar files 
> visible to the built part. Any suggestion?
> 
> 
> 
> 
> Samuel...............Have  a great day.
> 
> IBM WebSphere Development ("Web Services Engine") {
>      phone = "(512) 838-4963, T/L : 678-4963";
>      internet  = "soi@us.ibm.com";
> }
> 
> 
> 
> Davanum Srinivas <davanum@gmail.com>
> 02/06/2006 04:30 PM
> Please respond to
> axis-dev@ws.apache.org
> 
> 
> To
> axis-dev@ws.apache.org
> cc
> 
> Subject
> Re: [Axis2] -- Problem building ver 0.94
> 
> 
> 
> 
> 
> 
> http://cvs.apache.org/repository/ws-commons/jars/
> 
> 
> On 2/6/06, Samuel Isokpunwu <soi@us.ibm.com>wrote:
>   
> 
> I am having dependency errors trying to build Axis2 version 0.94
> source 
>     
> code
>   
> packaged as  axis2-std-0.94-src.zip. The XmlSchema-SNAPSHOT.jar and
> ws-policy-SNAPSHOT.jar are missing. Where can I find these dependency 
>     
> jars.
>   
> 
> 
> 
> Samuel...............Have  a great day.
> 
> IBM WebSphere Development ("Web Services Engine") {
>      phone = "(512) 838-4963, T/L : 678-4963";
>      internet  = "soi@us.ibm.com";
> }
>     
> 
> 
> --
> Davanum Srinivas : http://wso2.com/blogs/
> 
> 
>   


Mime
View raw message