axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ajith Ranabahu <ajith.ranab...@gmail.com>
Subject Re: [axis2] unable to run client
Date Thu, 12 Jan 2006 06:25:45 GMT
Hi Simon,
You just found a major bug in the 0.94 distributions : we've forgotten to
package the addressing mar into the axis2-core-0.94.jar.

The workaround is to copy the addressing.mar into the right place. This is
what you should do.

* Copy addressing.mar from the modules/ directory of the standard
distribution into the ".axis2/modules" directory in your home directory.

Now everything should work. We are working on an updated release; sorry for
the pain!

Ajith

On 1/12/06, Simon Fell <sfell@salesforce.com> wrote:
>
> Following along a similar set of steps to those outlined in the
> databinding client part of the docs, i ran WSDL2Code on the wsdl with the
> option to use xmlbeans. In my client, i new up an instance of the generated
> stub, SoapStub stub = new SoapStub(); leaves me with this when i try and run
> my code
>
> - Module validation failed  module.xml not found  for the module :
> addressing; nested exception is:
>         org.apache.axis2.deployment.DeploymentException: module.xml not
> found  for the module :   addressing
> Exception in thread "main" org.apache.axis2.deployment.DeploymentException:
> module.xml not found  for the module :   addressing; nested exception is:
>         org.apache.axis2.deployment.DeploymentException: module.xml not
> found  for the module :   addressing; nested exception is:
>         org.apache.axis2.deployment.DeploymentException: module.xml not
> found  for the module :   addressing; nested exception is:
>         org.apache.axis2.deployment.DeploymentException: module.xml not
> found  for the module :   addressing
>         at org.apache.axis2.deployment.DeploymentEngine.load(
> DeploymentEngine.java:542)
>         at
> org.apache.axis2.deployment.FileSystemConfigurator.getAxisConfiguration(
> FileSystemConfigurator.java:56)
>         at
> org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContext
> (ConfigurationContextFactory.java:39)
>         at
> org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContextFromFileSystem
> (ConfigurationContextFactory.java:53)
>         at org.apache.axis2.client.ServiceClient.<init>(ServiceClient.java
> :86)
>         at org.apache.axis2.SoapStub.<init>(SoapStub.java:144)
>         at testClient.main(testClient.java:20)
> Caused by: org.apache.axis2.deployment.DeploymentException: module.xml not
> found  for the module :   addressing; nested exception is:
>         org.apache.axis2.deployment.DeploymentException: module.xml not
> found  for the module :   addressing
>         at
> org.apache.axis2.deployment.repository.util.ArchiveReader.creatModuleArchivefromResource
> (ArchiveReader.java:193)
>         at
> org.apache.axis2.engine.AxisConfiguration.loadModulefromResources(
> AxisConfiguration.java:385)
>         at org.apache.axis2.engine.AxisConfiguration.engageModule(
> AxisConfiguration.java:328)
>         at org.apache.axis2.deployment.DeploymentEngine.engageModules(
> DeploymentEngine.java:502)
>         at org.apache.axis2.deployment.DeploymentEngine.load(
> DeploymentEngine.java:537)
>         ... 6 more
> Caused by: org.apache.axis2.deployment.DeploymentException: module.xml not
> found  for the module :   addressing
>         at
> org.apache.axis2.deployment.repository.util.ArchiveReader.creatModuleArchivefromResource
> (ArchiveReader.java:158)
>         ... 10 more
>
>
> If i need a module.xml to run the client, shouldn't WSDL2Code spit out a
> default one for me ?
>
> Thanks
> Simon
>



--
Ajith Ranabahu

Mime
View raw message