axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tom Jordahl (JIRA)" <axis-...@ws.apache.org>
Subject [jira] Closed: (AXIS-2343) NoSuchMethodError:javax.xml.namespace.QName.getPrefix with WSDL2Java
Date Fri, 16 Dec 2005 16:15:47 GMT
     [ http://issues.apache.org/jira/browse/AXIS-2343?page=all ]
     
Tom Jordahl closed AXIS-2343:
-----------------------------

    Resolution: Invalid

This indicates you have another version of the QName classes that were loaded instead of the
ones in jaxrpc.jar.  Older versions old wsdl4j have the older classes in them.

> NoSuchMethodError:javax.xml.namespace.QName.getPrefix with WSDL2Java
> --------------------------------------------------------------------
>
>          Key: AXIS-2343
>          URL: http://issues.apache.org/jira/browse/AXIS-2343
>      Project: Apache Axis
>         Type: Bug
>   Components: WSDL processing
>     Versions: 1.3
>  Environment: Windows2000, jdk1.4.2, AXIS1.3, bug also with AXIS1.4 nightly built
>     Reporter: uwe kraemer

>
> By creating java classes with WSDL2Java occurs a very strange error:
> D:\Java>java org.apache.axis.wsdl.WSDL2Java d:\java\AddressBook.wsdl
> java.lang.NoSuchMethodError: javax.xml.namespace.QName.getPrefix()Ljava/lang/Str
> ing;
>         at org.apache.axis.wsdl.symbolTable.BackslashUtil.getQNameWithDifferentL
> ocal(BackslashUtil.java:62)
>         at org.apache.axis.wsdl.symbolTable.BackslashUtil.getQNameWithBackslashl
> essLocal(BackslashUtil.java:39)
>         at org.apache.axis.wsdl.symbolTable.SymbolTable.populateServices(SymbolT
> able.java:3078)
>         at org.apache.axis.wsdl.symbolTable.SymbolTable.populate(SymbolTable.jav
> a:745)
>         at org.apache.axis.wsdl.symbolTable.SymbolTable.add(SymbolTable.java:543
> )
>         at org.apache.axis.wsdl.symbolTable.SymbolTable.populate(SymbolTable.jav
> a:518)
>         at org.apache.axis.wsdl.symbolTable.SymbolTable.populate(SymbolTable.jav
> a:495)
>         at org.apache.axis.wsdl.gen.Parser$WSDLRunnable.run(Parser.java:361)
>         at java.lang.Thread.run(Thread.java:534)
> This bug occurs with AXIS1.3 released and also with AXIS1.4 nightly built 16.12.05
> Any ideas, why??? 

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message