axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davanum Srinivas (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AXIS2-293) Umlauts (e.g. äöü) are not correctly handled
Date Thu, 01 Dec 2005 23:10:32 GMT
     [ http://issues.apache.org/jira/browse/AXIS2-293?page=all ]

Davanum Srinivas updated AXIS2-293:
-----------------------------------

    Attachment: echo.wsdl

Tried WSDL2Java generated code using this wsdl. ("java org.apache.axis2.wsdl.WSDL2Java -o
work -s -p test.echo -t -ss -sd -uri echo.wsdl"). works fine for me. See test code snippet
below.

    public void testecho() throws java.lang.Exception {
        test.echo.EchoPortTypeStub stub = new test.echo.EchoPortTypeStub(); 
                                                                            
        stub.setWsaAction("echo");
        EchoRequestDocument request = EchoRequestDocument.Factory.newInstance();
        EchoResponseDocument response;

        request.setEchoRequest("Foo!Bar");
        response = stub.echo(request);
        System.out.println("[" + response + "]");

        request.setEchoRequest("äöüabc");
        response = stub.echo(request);
        System.out.println("[" + response + "]");
        assertEquals(request.getEchoRequest(),response.getEchoResponse());

        request.setEchoRequest("1ö2ä3");
        response = stub.echo(request);
        System.out.println("[" + response + "]");
        assertEquals(request.getEchoRequest(),response.getEchoResponse());

        request.setEchoRequest("123äöü");
        response = stub.echo(request);
        System.out.println("[" + response + "]");
        assertEquals(request.getEchoRequest(),response.getEchoResponse());
    }

thanks,
dims

> Umlauts (e.g. äöü) are not correctly handled
> --------------------------------------------
>
>          Key: AXIS2-293
>          URL: http://issues.apache.org/jira/browse/AXIS2-293
>      Project: Apache Axis 2.0 (Axis2)
>         Type: Bug
>   Components: core
>     Versions: 0.92
>     Reporter: Yves Langisch
>  Attachments: echo.wsdl
>
> I have a simple EchoService and tested it with different strings. I have strange problems
with umlauts. If I have umlauts at the beginning or in the middle of the echo string (like
äöüabc or 1ö2ä3) everything works fine. But if I have umlauts at the end of the string,
like 123äöü, the umlauts are disapearred and I just get 123 in my skeleton class. It's
not XmlBeans that causes the problem since the string to be deserialized is already cut as
far as I can see it.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message