axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Davanum Srinivas <dava...@gmail.com>
Subject Re: [Axis2] building under java1.5
Date Fri, 28 Oct 2005 15:57:24 GMT
Steve,

all org.w3c imports are ONLY in org.apache.axis2.om.impl.dom.*
package. This can be ripped out w/o affecting xml module.

-- dims

On 10/28/05, Davanum Srinivas <davanum@gmail.com> wrote:
> that's wrong...OMElement should not depend on DOM2...let me check.
>
> -- dims
>
> On 10/28/05, Steve Loughran <stevel@apache.org> wrote:
> > Davanum Srinivas wrote:
> > > Should we break out the DOM2/DOM3 stuff from xml module? just like we
> > > did for saaj?
> > >
> >
> > well, the issue is that both the OMElement and the SAAJ stuff declare
> > that they implement the dom interfaces, and you cannot build them on
> > java1.5 without marking every impl class as abstract. So I dont think
> > 'breaking out' is something
> > we can do.
> >
>
>
> --
> Davanum Srinivas : http://wso2.com/blogs/
>


--
Davanum Srinivas : http://wso2.com/blogs/

Mime
View raw message