axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Johnson <e...@tibco.com>
Subject Re: (501)Not Implemented + CommonsHTTPSender +NTLM + Proxy
Date Thu, 29 Sep 2005 17:37:12 GMT
Nicolas,

I'm thinking you'll get a better answer over at 
httpclient-dev@jakarta.apache.org, where the NTLM experts can respond.

It may be that you just cannot do what you want, in that the Squid proxy 
effectively blocks NTLM authentication.  Have you tried setting your IE 
web browser to use the Squid proxy, and see if that works with some NTLM 
authenticated site?

-Eric.

Nicolas Clement wrote:

> Hello,
>
> In order to deal with a Web Service that is expecting NTLM 
> authentication, I have modified the Axis configuration to make Axis 
> use CommonsHTTPSender. It is working well until I have to go through a 
> proxy (squid). When going through a proxy, I have a "(501)Not 
> Implemented" error message.
>
> Thank you very much for your help,
>
> Nicolas
>
> This message contains information that may be privileged or 
> confidential and is the property of the Capgemini Group. It is 
> intended only for the person to whom it is addressed. If you are not 
> the intended recipient, you are not authorized to read, print, retain, 
> copy, disseminate, distribute, or use this message or any part 
> thereof. If you receive this message in error, please notify the 
> sender immediately and delete all copies of this message.
>

Mime
View raw message