axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Glen Daniels <>
Subject Re: [Axis2] Context Hierarchy
Date Wed, 14 Sep 2005 03:49:12 GMT
Hi Chinthaka:

> ConfigurationContext                   AxisConfiguration
>            |                                                  |
> ServiceGroupContext                  ServiceGroupDescription
>            |                                                  |
> ServiceContext                           ServiceGroupDescription
>           |                                                   |
> OperationContext                       ServiceDescription
>          |
> MessageContext                       

Assuming you meant ServiceContext->ServiceDescription, 
OperationContext->OperationDescription, and MessageContext->??

> For consistancy and clarity, I'd like to propose to do a small name change.
>    1. ConfigurationContext --> AxisContext
>    2. AxisConfiguration --> AxisDescription

+1 to AxisContext (this was "EngineContext" originally).  For the 
"description" hierarchy, I'll suggest another alternative which I've 
been meaning to bring up for a while:

OperationDescription -> AxisOperation
ServiceDescription -> AxisService
ServiceGroupDescription -> ServiceGroup
AxisConfiguration stays the same

The reason for this is twofold - first, the "description" suffix isn't 
really necessary, and I think might be confusing with WSDL descriptions 
(yes, the classes relate to WSDL structure, but the whole reason we have 
our own classes which inherit from the WSDL ones is to add Axis-specific 
stuff that usually does NOT get reflected in the WSDL).  Second, these 
are the names (except of course ServiceGroup) that we agreed to at the 
first F2F.

The reason I didn't make it "AxisServiceGroup" is simply that 
ServiceGroup isn't going to be as frequently used a class name as 
"Operation" and "Service" might be.  I'd be OK with that too.

> We do always have naming wars, hope this will not be another one :)

Naming is really important. :)  It's worth hashing it out.


View raw message