axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Deepal Jayasinghe" <dee...@opensource.lk>
Subject Re: onto next build failure...
Date Thu, 08 Sep 2005 07:36:46 GMT
Hi ;

The problem is your maven version I guess , as I know there are some problem 
in beta version , so if you are using that pls try with some other version 
(1.0.1)


Thanks,
 Deepal
................................................................
~Future is Open~



----- Original Message ----- 
From: "Dean Hiller" <dean@xsoftware.biz>
To: <axis-dev@ws.apache.org>
Sent: Thursday, September 08, 2005 10:46 AM
Subject: onto next build failure...


> any ideas on what is wrong now(failure just below)...thanks, dean
>
> Attempting to download axis2-xml-0.91.jar.
> WARNING: Failed to download axis2-xml-0.91.jar.
> Attempting to download axis2-common-0.91.jar.
> WARNING: Failed to download axis2-common-0.91.jar.
>
> BUILD FAILED
> File...... C:\Documents and 
> Settings\fastdragon\.maven\cache\maven-multiproject-
> plugin-1.4.1\plugin.jelly
> Element... maven:reactor
> Line...... 218
> Column.... -1
> The build cannot continue because of the following unsatisfied 
> dependencies:
>
> axis2-xml-0.91.jar
> axis2-common-0.91.jar
>
> Total time   : 2 minutes 16 seconds
> Finished at  : Wednesday, September 7, 2005 10:43:44 PM MDT
>
>
> Ruchith Fernando wrote:
>
>>Hi,
>>
>>This was due to some recent refactoring in the WSS4J project and the
>>SNAPSHOT  is updated to the latest now. Glen has updated the
>>Axis2-Security module and fixed this... build is fine now :-)
>>
>>Thanks
>>Ruchith
>>
>>On 9/8/05, Dean Hiller <dean@xsoftware.biz> wrote:
>>
>>>So I know switched to 1.4.2_09 and ran
>>>1. maven clean
>>>2. ran steps again on web 
>>>page....http://ws.apache.org/axis2/maven-help.html
>>>3. maven
>>>
>>>The failure now is attached below.  What version of maven are you
>>>using?  It would be very nice if when I checked out axis, maven and ant
>>>came with it and there was a build.bat that just had a call to the maven
>>>that came with axis.  Then I would never have to upgrade maven nor ant,
>>>as when someone upgraded it in axis2, everyone would get the update when
>>>they update their code base.  I did this on previous projects with just
>>>ant and it worked great(developers could still have ant installed on
>>>their machine if they wanted, but it let them not worry about it).
>>>
>>>Current failure:
>>>    [javac]
>>>C:\ABROOT\views\jakarta\axis2\modules\security\src\org\apache\axis2\
>>>security\WSDoAllSender.java:211:
>>>performENCRAction(int,boolean,org.w3c.dom.Docum
>>>ent,org.apache.ws.security.handler.RequestData) in
>>>org.apache.ws.security.handle
>>>r.WSHandler cannot be applied to
>>>(boolean,int,org.w3c.dom.Document,org.apache.ws
>>>.security.handler.RequestData)
>>>    [javac]                     performENCRAction(mu, actionToDo, doc,
>>>reqData);
>>>
>>>    [javac]                     ^
>>>    [javac] 1 error
>>>
>>>BUILD FAILED
>>>File...... C:\Documents and
>>>Settings\fastdragon\.maven\cache\maven-multiproject-
>>>plugin-1.4.1\plugin.jelly
>>>Element... maven:reactor
>>>Line...... 218
>>>Column.... -1
>>>Unable to obtain goal [multiproject:install-callback] -- C:\Documents
>>>and Settin
>>>gs\fastdragon\.maven\cache\maven-java-plugin-1.5\plugin.jelly:63:-1:
>>><ant:javac>
>>> Compile failed; see the compiler error output for details.
>>>Total time   : 2 minutes 19 seconds
>>>Finished at  : Wednesday, September 7, 2005 8:47:21 PM MDT
>>>
>>>thanks,
>>>dean
>>>
>>>
>>>
>>>
>>
>>
>>
>
> 



Mime
View raw message