axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thilina Gunarathne <cset...@gmail.com>
Subject Re: [Axis2][ShowStopper] mtom severly broken...when running in to mcat
Date Fri, 12 Aug 2005 05:16:19 GMT
I fixed the issue.. (Actually it started to work on my machine after some 
modifications).. I still couldn't figure out why it happened..The problem 
did not arise in Simple Axis server at all ....

Can somebody test the sample this......

Thanks,
~Thilina

On 8/11/05, Ed Saltelli <eduardo.saltelli@webmethods.com> wrote:
> 
> Actually it is not mandatory in 1.0 since the default behavior is to close
> the connection; only mandatory if you have a connection: keep-alive.
> 
> For 1.1 you can avoid setting the length on the HTTP header if you're
> chunking or if you explicitly send a conneciton: close.
> 
> 
> 
> -----Original Message-----
> From: Davanum Srinivas [mailto:davanum@gmail.com]
> Sent: Wednesday, August 10, 2005 11:21 PM
> To: Thilina Gunarathne
> Cc: axis-dev@ws.apache.org
> Subject: Re: [Axis2][ShowStopper] mtom severly broken...when running in
> tomcat
> 
> Yes, It is "mandatory in HTTP 1.0 to set the content-length"
> 
> -- dims
> 
> On 8/10/05, Thilina Gunarathne <csethil@gmail.com> wrote:
> > Hi,
> > I just came.... Any progress ... What i believed is there is no need ot
> > set Content-Length in MIME messages, Since they depend on Boundaries...
> If
> > we are going to set the content-length we have to buffer the whole 
> message
> > in memory...
> >
> > Is it mandatory in HTTP 1.0 to set the content-length...
> >
> > ~Thilina
> >
> >
> > On 8/11/05, Davanum Srinivas <davanum@gmail.com> wrote:
> > > Found the problem...maybe thilina can fix it quicker than me.
> > > content-length in http header is not set correctly when using mtom
> > > (default is HTTP1.0 in axis2.xml and content-length has to be set
> > > correctly in this case)
> > >
> > > -- dims
> > >
> > > On 8/10/05, Davanum Srinivas <davanum@gmail.com> wrote:
> > > > Thilina,
> > > >
> > > > Please deploy the imagetransfer's mtomSample.aar file and run the
> > > > client in mtomClient.jar. Am getting
> > > > "javax.xml.stream.XMLStreamException". Am still
> > debugging. looks bad.
> > > >
> > > > -- dims
> > > >
> > > > --
> > > > Davanum Srinivas : http://wso2.com/ - Oxygenating The Web Service
> > Platform
> > > >
> > >
> > >
> > > --
> > > Davanum Srinivas : http://wso2.com/ - Oxygenating The Web Service
> Platform
> > >
> >
> >
> >
> > --
> > "May the SourcE be with u"
> > http://www.bloglines.com/blog/thilina
> 
> 
> --
> Davanum Srinivas : http://wso2.com/ - Oxygenating The Web Service Platform
> 



-- 
"May the SourcE be with u" 
http://www.bloglines.com/blog/thilina

Mime
View raw message