axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Meghan Pietila (JIRA)" <>
Subject [jira] Created: (AXIS-2177) encodingStyle atttribute not set on SOAP envelope
Date Thu, 11 Aug 2005 14:44:55 GMT
encodingStyle atttribute not set on SOAP envelope

         Key: AXIS-2177
     Project: Apache Axis
        Type: Bug
  Components: Serialization/Deserialization  
    Versions: 1.2.1    
    Reporter: Meghan Pietila

In the Call.invoke(RPCElement) method, there is a code snippet with a comment:  "Set both
the envelope and the RPCElement encoding styles".  However, the code then proceeds to set
only the RPCElement encoding style.  Later, this results in the encodingStyle attribute being
set only on the first element in the SOAP body (if the entire message is the same encoding
style)--see example below.

This is causing a problem for me in an RPC/encoded service call to a SOAP service hosted by
Siebel.  Our developer tells me that their parser expects to find the encodingStyle attribute
in the SOAP Envelope or SOAP Body elements, and cries when it can't find the attribute there.

I believe all that is necessary is to add the following line, immediately after the comment
and start of try { block:

Example of current Axis output:

<?xml version="1.0" encoding="UTF-8"?>
<soapenv:Envelope xmlns:soapenv="" xmlns:xsd=""
    <ns1:GetOffersByCustomer soapenv:encodingStyle=""
      <CustomerType xsi:type="xsd:string">Consumer</CustomerType>
      <LPID xsi:type="xsd:string">1234567</LPID>

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:

View raw message