axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dong Liu <edong...@gmail.com>
Subject Re: [Axis2]Dependency on Crimson
Date Sun, 10 Jul 2005 15:11:48 GMT
The same issue is found when testing the WSDL2Java facility on Java SE
5 described in the user guide. The message

>WSDL2Java -uri ..\samples\wsdl\Axis2SampleDocLit.wsdl -ss -sd -o
..\samples\src -p org.apache.axis2.userguide
Exception in thread "main" java.lang.NoClassDefFoundError:
org/apache/crimson/tree/XmlDocument
        at org.apache.axis2.wsdl.codegen.emitter.MultiLanguageClientEmitter.createDOMDocuementForSkeleton(MultiLanguageClientEmitter.java:524)
        at org.apache.axis2.wsdl.codegen.emitter.MultiLanguageClientEmitter.writeSkeleton(MultiLanguageClientEmitter.java:220)
        at org.apache.axis2.wsdl.codegen.emitter.MultiLanguageClientEmitter.emitSkeleton(MultiLanguageClientEmitter.java:345)
        at org.apache.axis2.wsdl.codegen.CodeGenerationEngine.generate(CodeGenerationEngine.java:100)
        at org.apache.axis2.wsdl.WSDL2Code.main(WSDL2Code.java:28)
        at org.apache.axis2.wsdl.WSDL2Java.main(WSDL2Java.java:22)

Cheers,

Don

On 7/9/05, Davanum Srinivas <davanum@gmail.com> wrote:
> +1 to fix this ASAP!
> 
> On 7/9/05, Changshin Lee <iasandcb@gmail.com> wrote:
> > Hi all,
> >
> > I found that
> > org.apache.axis2.wsdl.codegen.emitter.MultiLanguageClientEmitter used
> > org.apache.crimson.XmlDocument, which causes Axis 2 WSDL2Java to fail to
> > run on Java SE 5. The reason is that Sun's JDK 1.4 contains Crimson as a
> > JAXP implementation and Java SE 5 doesn't. As we agreed, Axis 2 should
> > be able to be build and run on Java SE 5.
> >
> > Cheers,
> >
> > Ias
> >
> 
> 
> --
> Davanum Srinivas -http://blogs.cocoondev.org/dims/
>

Mime
View raw message