axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luis Rivera" <luigg...@hotmail.com>
Subject Re: Problems compiling Axis1.2.1
Date Sat, 23 Jul 2005 12:30:59 GMT

Hi again,

Thanks for the reply. I am now compiling with the j2sdk1.4.2_08. Now I have 
a new problem, which I think has to do with the endorsed standards classes. 
But I can't find a way to specify them in the ant build.xml file. The error 
is below. I have the two jar files (xercesImpl.jar and xmlParserAPIs.jar) 
that have the required classes, but java refuses to see them. I know there 
is a property (java.endorsed.dirs), which I believe I could specify as 
${lib.dir} somewhere in the ant file .. or should it be in each target?

java.lang.NoClassDefFoundError: org/w3c/dom/ranges/DocumentRange
        at 
org.apache.xerces.validators.dtd.DTDGrammar.callStartDTD(DTDGrammar.java:194)
        at 
org.apache.xerces.framework.XMLDTDScanner.scanDoctypeDecl(XMLDTDScanner.java:1079)
        at 
org.apache.xerces.framework.XMLDocumentScanner.scanDoctypeDecl(XMLDocumentScanner.java:22
01)
        at 
org.apache.xerces.framework.XMLDocumentScanner.access$0(XMLDocumentScanner.java:2156)
        at 
org.apache.xerces.framework.XMLDocumentScanner$PrologDispatcher.dispatch(XMLDocumentScanner.java:887)
        at 
org.apache.xerces.framework.XMLDocumentScanner.parseSome(XMLDocumentScanner.java:381)
        at org.apache.xerces.framework.XMLParser.parse(XMLParser.java:1035)
        at 
org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:217)
        at 
org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:140)
        at 
org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.java:91)
        at org.apache.tools.ant.Main.runBuild(Main.java:653)
        at org.apache.tools.ant.Main.startAnt(Main.java:187)
        at org.apache.tools.ant.launch.Launcher.run(Launcher.java:246)
        at org.apache.tools.ant.launch.Launcher.main(Launcher.java:67)

Any help will be appreicated,

--Luis R.

>From: Davanum Srinivas <davanum@gmail.com>
>Reply-To: dims@apache.org
>To: axis-dev@ws.apache.org
>Subject: Re: Problems compiling Axis1.2.1
>Date: Sat, 23 Jul 2005 05:02:27 -0400
>
>there are some steps to doing this using jdk1.5...but i'd rather you
>compile using JDK1.4 using the ant/build.xml from the command line.
>
>-- dims
>
>On 7/22/05, Luis Rivera <luiggiil@hotmail.com> wrote:
> >
> > Hi,
> >
> > Well, I finally found time to try to build Axis1.2.1 to see if I can get 
>rid
> > of the NullSecManager() when using axis in an applet. However, I cannot 
>even
> > compile it, it gives me lots of warnings, complaining about using "enum 
>as a
> > keyword", then I change the source to 1.5 and they become errors. Also,
> > there are errors regarding incomplete interface implementations, which I
> > believe is more about correcting the previous warnings first.
> >
> > Here is the error list, I reduced the error to only a handfull the rest 
>are
> > just the same. Any help will be appreicated. I am using the jdk1.5.0_03 
>to
> > compile and running ant from Eclipse. However, even runnig out to 
>compile
> > form the command line give me the same errors.
> >
> >   --Luis R.
> >
> >   [javac]
> > 
>C:\perforce\verimatrix\Dev\Luis\axis\axis-1_2_1\src\org\apache\axis\enum\Scope.java:17:
> > warning: as of release 1.5, 'enum' is a keyword, and may not be used as 
>an
> > identifier
> >     [javac] (try -source 1.5 to use 'enum' as a keyword)
> >     [javac] package org.apache.axis.enum;
> >     [javac] ^
> > ...
> >     [javac]
> > 
>C:\perforce\verimatrix\Dev\Luis\axis\axis-1_2_1\src\org\apache\axis\components\net\SunFakeTrustSocketFactory.java:24:
> > warning: [deprecation] com.sun.net.ssl.SSLContext in com.sun.net.ssl has
> > been deprecated
> >     [javac] import com.sun.net.ssl.SSLContext;
> >     [javac] ^
> > ...
> >     [javac]
> > 
>C:\perforce\verimatrix\Dev\Luis\axis\axis-1_2_1\src\org\apache\axis\message\NodeImpl.java:45:
> > org.apache.axis.message.NodeImpl is not abstract and does not override
> > abstract method getUserData(java.lang.String) in org.w3c.dom.Node
> >     [javac] public class NodeImpl implements org.w3c.dom.Node,
> > javax.xml.soap.Node,
> >     [javac] ^
> > ...
> >     [javac]
> > 
>C:\perforce\verimatrix\Dev\Luis\axis\axis-1_2_1\src\org\apache\axis\components\net\SunJSSESocketFactory.java:82:
> > warning: [deprecation] com.sun.net.ssl.SSLContext in com.sun.net.ssl has
> > been deprecated
> >     [javac] SSLContext context = getContext();
> >     [javac] ^
> > ...
> >     [javac]
> > 
>C:\perforce\verimatrix\Dev\Luis\axis\axis-1_2_1\src\org\apache\axis\utils\SOAPMonitor.java:2625:
> > warning: [deprecation] show() in java.awt.Dialog has been deprecated
> >     [javac] dialog.show();
> >     [javac] ^
> >     [javac] 16 errors
> >     [javac] 35 warnings
> >
> > _________________________________________________________________
> > Express yourself instantly with MSN Messenger! Download today - it's 
>FREE!
> > http://messenger.msn.click-url.com/go/onm00200471ave/direct/01/
> >
> >
>
>
>--
>Davanum Srinivas -http://blogs.cocoondev.org/dims/

_________________________________________________________________
Donít just search. Find. Check out the new MSN Search! 
http://search.msn.click-url.com/go/onm00200636ave/direct/01/


Mime
View raw message