axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Davanum Srinivas <dava...@gmail.com>
Subject Re: [Axis2] NullPointerException
Date Mon, 18 Jul 2005 02:16:46 GMT
i have comments on all my svn check-ins. if am missed any of them,
please let me know which one and i will be happy to oblige. hold off
on your check-in for a day more. please let me finish one more thing
(fix geronimo activation/javamail) for our test cases.

thanks,
dims


On 7/17/05, Thilina Gunarathne <csethil@gmail.com> wrote:
> Hi Dims, 
> I got a update on Friday and it seeemed MTOM is not working. So I did some
> fixes. I doubt whether we both will overlap the things. 
> SVN is down :(.  No way of checking the things u did. 
> Can u pls specify the things u did....
>   
> Regards, 
> ~Thilina
>  
> 
>   
> On 7/16/05, Davanum Srinivas <davanum@gmail.com> wrote: 
> > Simon,
> > 
> > I got this working just yesterday. You will need to compile Axis2 from
> > latest SVN.
> > 
> > Have u set up the hands on lab sample?
> >
> http://www.microsoft.com/downloads/details.aspx?familyid=0E5491C1-8BDE-4FFF-88C4-8E3DC102FAD6&displaylang=en
> > 
> > If you did, i have an example that works with Part3\after sample.
> > 
> > Step #1: Basically start with adding another method in
> > CS\Part3\after\StockServiceLibrary\StockService.cs
> > 
> >        [WebMethod]
> >        public byte[] echoAttachment(byte[] bytes) {
> >                        return bytes;
> >        }
> > 
> > Step #2: Run .NET's wsdl.exe (NOT wsewsdl3.exe) against the dynamic
> > wsdl, add a main and test the method.
> > 
> >    public static void Main(string[] args) {
> >                StockService service = new StockService();
> >                byte[] bytes = null;
> >                service.RequireMtom = true;
> >        using (FileStream fs = new FileStream(" gears.gif",
> > FileMode.Open, FileAccess.Read, FileShare.Read))
> >        {
> >            byte[] buffer = new byte[fs.Length];
> >            fs.Read(buffer, 0, (int)fs.Length);
> >            bytes = service.echoAttachment (buffer);
> >        }
> >    }
> > 
> > Step #3: compile the attached java code and run it.
> > 
> > Thanks,
> > dims
> > 
> > PS: check my blogs for 2 lists of bugs in WSE 3.0 CTP
> > (http://blogs.cocoondev.org/dims/ )
> > 
> > On 7/15/05, Simon Guest <sguest@microsoft.com> wrote:
> > >
> > >
> > >
> > > I'm working on an MTOM interop sample between Axis 2 0.9 and WSE 3.0
> CTP.
> > > When I try to run WSDL2Java in the Axis 2 installation, I get the
> following
> > > exception:
> > >
> > >
> > >
> > > C:\axis2-0.9-bin>wsdl2java -uri c:\temp\MTOM.wsdl
> > >
> > > Exception in thread "main" java.lang.NullPointerException
> > >
> > >         at
> > >
> org.apache.axis2.wsdl.codegen.CodeGenConfiguration.<init>(CodeGenConf
> > >
> > > iguration.java:79)
> > >
> > >         at
> > > org.apache.axis2.wsdl.codegen.CodeGenConfiguration
> .<init>(CodeGenConf
> > >
> > > iguration.java:72)
> > >
> > >         at
> > >
> org.apache.axis2.wsdl.codegen.CodeGenerationEngine.<init>(CodeGenerat
> > >
> > > ionEngine.java:61)
> > >
> > >         at 
> > > org.apache.axis2.wsdl.WSDL2Code.main(WSDL2Code.java:28)
> > >
> > >         at
> > > org.apache.axis2.wsdl.WSDL2Java.main(WSDL2Java.java:22)
> > >
> > >
> > >
> > > This problem doesn't seem related to the WSDL (I tried with one in the
> Axis 
> > > 2 samples directory).  I've also tried this on both JDK 1.4.2 and 1.5 –
> same
> > > issue.
> > >
> > >
> > >
> > > Any ideas?
> > >
> > >
> > >
> > > Thanks,
> > >
> > > -Simon
> > 
> > 
> > --
> > Davanum Srinivas -http://blogs.cocoondev.org/dims/
> > 
> > 
> 
> 
> 
> -- 
> "May the SourcE be with u" 
>  http://www.bloglines.com/blog/thilina 


-- 
Davanum Srinivas -http://blogs.cocoondev.org/dims/
Mime
View raw message