axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kador, Daniel" <daniel.ka...@lmco.com>
Subject RE: [Axis2] Code Emitter Broken?
Date Wed, 06 Jul 2005 13:11:29 GMT
Gah... You're all certainly correct.  My mistake.  It seems a JIRA
report has already been filed by Chathura, so unless somebody asks me to
file a bug, I'll assume it's been handled.

Glad my stupidity got commented on several times over.  If anybody could
take a look at my other topic on the code emitter, that'd be great.
Maybe I did something stupid there too, although I don't think so.  At
least I didn't do the SAME stupid thing - my schemas all definitely have
a targetNamespace. :)

Thanks,
Dan

-----Original Message-----
From: Glen Daniels [mailto:glen@thoughtcraft.com] 
Sent: Wednesday, July 06, 2005 8:57 AM
To: axis-dev@ws.apache.org
Subject: Re: [Axis2] Code Emitter Broken?


Anne Thomas Manes wrote:
> Just because Axis1 was willing to accept an error, that doesn't mean 
> that Axis2 has to, also. Please add a targetNamespace to the schema
> (targetNamespace="http://test.wsdl") and try again.

...not to mention filing a bug in Axis. :)  We shouldn't be encouraging 
people to use bad WSDLs, even taking into account "be liberal in what 
you accept".

--Glen

> On 7/6/05, Venkat Reddy <vreddyp@gmail.com> wrote:
> 
>>The WSDL works with Axis 1.2.1. Namespace for "testType" is taken as 
>>"http://test.wsdl". For example, the generated stub code has this line
>> :
>>param = new org.apache.axis.description.ParameterDesc(new
>>javax.xml.namespace.QName("", "testParam"), 
>>org.apache.axis.description.ParameterDesc.IN, new 
>>javax.xml.namespace.QName("http://test.wsdl", "testType"), 
>>wsdl.test.TestType.class, false, false);
>>
>>-venkat
>>
>>
>>On 7/6/05, Sanjiva Weerawarana <sanjiva@opensource.lk> wrote:
>>
>>>Are you sure this works with Axis1?? Your schema does not have a 
>>>targetNamespace .. and unless I'm really getting old that's not legit

>>>for WSDL.
>>>
>>>Sanjiva.
>>>
>>>On Tue, 2005-07-05 at 16:13 -0400, Kador, Daniel wrote:
>>>
>>>>It would help if I actually attached the WSDL...
>>>>
>>>>-----Original Message-----
>>>>From: Kador, Daniel
>>>>Sent: Tuesday, July 05, 2005 4:08 PM
>>>>To: axis-dev@ws.apache.org
>>>>Subject: [Axis2] Code Emitter Broken?
>>>>
>>>>
>>>>Hi,
>>>>
>>>>First, I'd like to say thanks to all the developers for their work 
>>>>on Axis2.  I'm looking forward to the finished product very much.
>>>>
>>>>One of the features of .9 that I'm trying to test is the code 
>>>>emitter. I've got a WSDL for a very basic web service.  It certainly

>>>>works for Axis 1.2.1, so there is no issue with the WSDL itself.  
>>>>I'll attach it. When I run "java org.apache.axis2.wsdl.WSDL2Java -o 
>>>>axis2 -ss true -sd true -uri test.wsdl" I get the following error:
>>>>
>>>>D:\data\eclipse\WSDL Test>java org.apache.axis2.wsdl.WSDL2Java -o 
>>>>axis2 -ss true -sd true -uri test.wsdl Exception in thread "main"
>>>>java.lang.RuntimeException:
>>>>org.apache.xmlbeans.XmlException: error: src-resolve.a: Could not  
>>>>find type 'testType@http://test.wsdl'. Do you mean to refer to the 
>>>>type named testType?
>>>>        at 
>>>>org.apache.axis2.wsdl.codegen.extension.XMLBeansExtension.engage(XML
>>>>Bean
>>>>sExtension.java:103)
>>>>        at
>>>>org.apache.axis2.wsdl.codegen.CodeGenerationEngine.generate(CodeGene
rati
>>>>onEngine.java:79)
>>>>        at org.apache.axis2.wsdl.WSDL2Code.main(WSDL2Code.java:28)
>>>>        at org.apache.axis2.wsdl.WSDL2Java.main(WSDL2Java.java:22)
>>>>Caused by: org.apache.xmlbeans.XmlException: error: src-resolve.a:
Could
>>>>not find type 'testType@http://test.wsdl'. Do y ou mean to refer to
the
>>>>type named testType?
>>>>        at
>>>>org.apache.xmlbeans.impl.schema.SchemaTypeSystemCompiler.compile(Sch
emaT
>>>>ypeSystemCompiler.java:225)
>>>>        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
Method)
>>>>        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown
Source)
>>>>        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown
>>>>Source)
>>>>        at java.lang.reflect.Method.invoke(Unknown Source)
>>>>        at
>>>>org.apache.xmlbeans.XmlBeans.compileXmlBeans(XmlBeans.java:641)
>>>>        at
>>>>org.apache.axis2.wsdl.codegen.extension.XMLBeansExtension.engage(XML
Bean
>>>>sExtension.java:69)
>>>>        ... 3 more
>>>>
>>>>It looks to me like a qualified/unqualified issue, but I don't know 
>>>>for sure.
>>>>
>>>>I've got another WSDL that spits out a different error, so I'll send

>>>>a second e-mail with the relevant details for that WSDL.
>>>>
>>>>Thanks,
>>>>Dan
>>>
>>>
> 

Mime
View raw message