axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From João Portela (JIRA) <axis-...@ws.apache.org>
Subject [jira] Created: (AXIS-2150) Error calling web service after a re-deploy
Date Thu, 28 Jul 2005 13:27:18 GMT
Error calling web service after a re-deploy
-------------------------------------------

         Key: AXIS-2150
         URL: http://issues.apache.org/jira/browse/AXIS-2150
     Project: Apache Axis
        Type: Bug
    Versions: 1.2.1    
 Environment: Java sdk1.4.2_06
JBoss 4.0.2 / TomCat 5.0 / WebSphere 6.0
    Reporter: João Portela



After a redeploy of an application (that called a web service), when I try to call a web service
the following error occurs: 

“Unable to locate a valid EngineConfigurationFactory”
java.lang.NullPointerException
        at org.apache.axis.client.Service.getEngineConfiguration(Service.java:812)
        at org.apache.axis.client.Service.getAxisClient(Service.java:103)
        at org.apache.axis.client.Service.(Service.java:112)
        at myapp.WebService1Soap_BindingStub.(Unknown Source)
        ...

Notes: 
 - I have an axis configuration file in my ear/war application file.

- It seems that after the redeploy it tries to use previous (load) configurations but due
to the redeploy, the configuration no longer exists.



-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message