axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Brandow (JIRA)" <axis-...@ws.apache.org>
Subject [jira] Updated: (AXIS-2131) issue with Axis 1.2/1.2.1 and complexType namespaces
Date Wed, 20 Jul 2005 15:36:50 GMT
     [ http://issues.apache.org/jira/browse/AXIS-2131?page=all ]

David Brandow updated AXIS-2131:
--------------------------------

    Attachment: Echo12RC3.wsdl

> issue with Axis 1.2/1.2.1 and complexType namespaces
> ----------------------------------------------------
>
>          Key: AXIS-2131
>          URL: http://issues.apache.org/jira/browse/AXIS-2131
>      Project: Apache Axis
>         Type: Bug
>   Components: WSDL processing
>     Versions: 1.2, 1.2.1
>     Reporter: David Brandow
>  Attachments: Echo.java, Echo121.wsdl, Echo12RC3.wsdl, Person.java
>
> I have two simple classes, com.test.Person (structure basically, 4 string fields, first,
middle, last and nick names, getters and setters) and com.test.Echo (which has an operation
that takes in a Person and returns it).  Prior to Axis 1.2, when I called
>     java2wsdl -n http://www.mynamespace.com/ --PkgtoNS com.test=http://test.com -l http://localhost:8080/Echo
com.test.Echo
> the resulting Echo.wsdl would have a complexType named Person in a schema whose targetNamespace
was http://test.com.  Thus, when I ran wsdl2java on that Echo.wsdl, the types matched.  However,
when I run the same command with Axis 1.2 or Axis 1.2.1, the resulting Echo.wsdl's complexType
named Person is in a schema whose targetNamespace is http://www.mynamespace.com/. The namespace
http://test.com no longer appears in Echo.wsdl at all. So when I run wsdl2java on it, the
types don't match anymore (com.test.Person vs. com.mynamespace.www.Person). This is far less
user-friendly, because I have to manually create a mapping between the two classes, the complexity
of that mapping growing as does the complexity of the Person type.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message