axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davanum Srinivas (JIRA)" <axis-...@ws.apache.org>
Subject [jira] Resolved: (AXIS-2126) 500 Internal Server error at org.apache.axis.transport.http.HTTPSender.readFromSocket
Date Thu, 21 Jul 2005 02:23:46 GMT
     [ http://issues.apache.org/jira/browse/AXIS-2126?page=all ]
     
Davanum Srinivas resolved AXIS-2126:
------------------------------------

    Resolution: Cannot Reproduce

neal,

this seems like a class loader problem. Please check if there are multiple copies of axis
jars in different places on your server. check with your vendor about where to put axis jars
etc. we can't do much.

sorry. thanks.

> 500 Internal Server error  at org.apache.axis.transport.http.HTTPSender.readFromSocket
> --------------------------------------------------------------------------------------
>
>          Key: AXIS-2126
>          URL: http://issues.apache.org/jira/browse/AXIS-2126
>      Project: Apache Axis
>         Type: Bug
>   Components: Deployment / Registries
>     Versions: 1.2.1
>  Environment: Orion 2.0 app server on XP and RedHat Linux 8.0,  Java version  1.4.2_04-b05
>     Reporter: neal neal
>     Priority: Blocker

>
> This is related to http://issues.apache.org/jira/browse/AXIS-2106
> Please kindly reopen the bug.  This is a blocker for me.
> I had added a comment and did not hear from you folks and was unsure how I could re-open
it via the GUI other than making a new bug and relate to my original.
> Per my last commment for bug# 2106 I had this:-
> java.lang.ClassCastException 
> at org.apache.axis.Message.setup(Message.java:341) 
> I looked at the relevant line(line 341 of Message.java)  in Axis 1.2.1 code (and lines
close to it  for getting the context ) which I am pasting here:-
> line 330: // Try to construct an AttachmentsImpl object for attachment
>         331: // functionality.
>         332: // If there is no org.apache.axis.attachments.AttachmentsImpl class,
>         333: // it must mean activation.jar is not present and attachments are not
>         334: // supported.
>         335: if (isAttachmentSupportEnabled(getMessageContext())) {
>         336:    // Construct one, and cast to Attachments.
>         337:    // There must be exactly one constructor of AttachmentsImpl, which
>         338:    // must take an org.apache.axis.Message!
>         339:    Constructor attachImplConstr = attachImpl.getConstructors()[0];
>         340:    try {
>         341:       mAttachments = (Attachments) attachImplConstr.newInstance(
>         342:          new Object[] { initialContents,
>         343:             contentType, contentLocation});
> Please help! 
> In dev (on Jdeveloper I have no problem) ..but in the real world(using Orion server)
 I have a problem and need to go to production in a jiffy.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message