axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sanjiva Weerawarana <>
Subject Re: [Axis2] Couple of quick comments
Date Wed, 04 May 2005 11:46:51 GMT
On Wed, 2005-05-04 at 10:49 +0600, Srinath Perera wrote:
> On 5/4/05, Glen Daniels <> wrote:
> > 1) I still like OperationContext WAY better than MEPContext.  When did
> > we decide on MEPContext?  WSDL calls them "operations"....  Consider
> > this a request to change it back, or at least VOTE on it.

I thought it was always MEPContext ... but I may have just convinced my
mind that's the case without that being the reality. My apologies.

> let me say Bit of histry how we end up here :)
> We use to  have both OperationContext and MEPcontext, 
> OperationContext - info for one operation across the lifetime of the operation
> MEPContext - ino for single message exchange, OperationContext has
> number of MEP context stored in it.

+1. As Srinath said later a MepContext represents the usage of an
operation. So OperationContext is not quite the right term for that; its
almost an OperationInstanceContext ... but I'd really rather not bring
the "instance" word here. I have no big problem with finding a better
word but we really must settle on the names at some point (soon!).

> Then we put the information in the OperationContext to the
> AxisOperation and get rid of Operation context.

OperationContext and AxisOperation have a 1-1 relationship - hence it
doesn't make sense to have both IMO. We really need AxisOperation
because that's what we're using to represent the metadata for each
operation (including the WSDL info). So rather than creating another
object to represent operation level context info, we might as well store
that in AxisOperation and not have OperationContext.

> Changing current MEPContext -> OperationContext might be wrong as it
> is about all "instance" of MEP, in that sense the name MEPContext is
> wrong too .. the mep context is about a "intraction" rather than
> "interaction pattern".

IMO these (InteractionPatternContext and InteractionContext) are better
words had WSDL gone ahead with s/operation/interaction/. Too late :-(.


View raw message