axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lisa Preston (JIRA)" <axis-...@ws.apache.org>
Subject [jira] Commented: (AXIS-1993) WSDL2Java 1.2 fails where 1.2RC3 worked (XML Signature XSD)
Date Tue, 17 May 2005 21:43:24 GMT
     [ http://issues.apache.org/jira/browse/AXIS-1993?page=comments#action_65621 ]
     
Lisa Preston commented on AXIS-1993:
------------------------------------

It seems that the problem stems from a change that was applied not long before the drop of
Axis1.2 Final that caused the default behavior of WSDL2Java to use "unwrapped" arrays in preference
to "wrapped" arrays.  The logic is not quite right for handling these situations:

#1: The changes made to SchemaUtils.java to check for a sequence definition within a complexType
that has only one element does not account for the fact that other tags may be in the complexType
definition as well (i.e. attribute (as in the case of the xmldsig-core-schema.xsd file that
is attached to this bug).  Using the unwrapped array method will probably ignore those attributes
and they will never get generated.

#2: The logic in SymbolTable.java also throws an exception in the case (as noted in a previous
comment) where an existing element is referenced by the element within the sequence. Even
though the element does exist, it isn't recognized as a defined type. It does not matter where
the element definition falls in the file for this, it always fails.  

It looks like there needs to be some reworking of this code in order to support the schemas
that are out there that already exist and their functionality has been broken as a result
of the recent changes. I would suggest that this change be documented somewhere (the release
notes, for example!!!) and perhaps not be the default behavior.

> WSDL2Java 1.2 fails where 1.2RC3 worked (XML Signature XSD)
> -----------------------------------------------------------
>
>          Key: AXIS-1993
>          URL: http://issues.apache.org/jira/browse/AXIS-1993
>      Project: Axis
>         Type: Bug
>   Components: WSDL processing
>     Versions: 1.2
>  Environment: MS Windows XP
>     Reporter: Micha³ Kochanowicz
>  Attachments: WymianaWS.wsdl, gen.bat, xmldsig-core-schema.xsd
>
> WSDL2Java tool fails with message:
> java.io.IOException: Type {http://www.w3.org/2000/09/xmldsig#}Reference is referenced
but not defined.
> Same file were processed without problems with version 1.2beta2, 1.2RC2 & 1.2RC3.
> I'll attach these files.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message