axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From babloosony <babloos...@gmail.com>
Subject Problem with Setting up Jakarta Logging with AXIS
Date Wed, 09 Mar 2005 17:14:59 GMT
Hi All,

I am using AXIS 1.2 RC2, IBM WSAD 5.1.2, IBM WebSphere 5.0 Test
Enviroment inside WSAD. I am trying to setup Jakarta Commons Logging
with my AXIS web application deployed using WSAD. I have my
commons-logging.properties file and
log4j.properties file in my WEB-INF\classes\lib directory. Basically I
want see all types(levels like TRACE, DEBUG, INFO, WARN, ERROR, FATAL)
of log messages that axis classes use when I expose or consume any web
service.
Below are the content for these files :


commons-logging.properties 
------------------------------
org.apache.commons.logging.Log=org.apache.commons.logging.impl.SimpleLog



log4j.properties
------------------------------
log4j.rootCategory=DEBUG, dest1
log4j.appender.dest1=org.apache.log4j.FileAppender
log4j.appender.dest1.File=log4j.log
log4j.appender.dest1.Append=false
log4j.appender.dest1.layout=org.apache.log4j.PatternLayout
log4j.appender.dest1.layout.ConversionPattern=%p %t %c - %m %n


Now, I tried to consume a web service that is deployed on AXIS using
standalone java client program. The problem is  neither I see axis any
debug level messages or its above level message neither in a file
called log4j.log which I  configured in my log4j.properties Nor in
WSAD WebSphere 5.0 Test Environment Console ?

Am I doing anything in my configuration. Please suggest ?



Thanks & Regards,
Kumar.

Mime
View raw message