axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tim Kagle (JIRA)" <axis-...@ws.apache.org>
Subject [jira] Commented: (AXIS-1898) java2wsdl --extraClasses does not add extraClasses option to deploy.wsdd
Date Tue, 22 Mar 2005 22:21:35 GMT
     [ http://issues.apache.org/jira/browse/AXIS-1898?page=comments#action_61395 ]
     
Tim Kagle commented on AXIS-1898:
---------------------------------

I think I've confused myself with this bug. The problem comes from the existence of the 2
tools java2wsdl and wsdl2java, so starting from the java server classes, generating the WSDL
and then the java client classes is a 2 step process and here's what I do:

Java Server Classes -> WSDL:
Java2WSDL --extraClasses ....

WSDL -> Java Stubs/Client Classes + server side deployment descriptor:
WSDL2Java --server-side ...

The problem is that deploy.wsdd is created by WSDL2Java so all the extraClasses information
from the first Java2WSDL call is lost, hence the auto-generated WSDL file by the Axis runtime
is incomplete, it doesn't include the extra classes.

I'm not sure what the solution here is short of editting deploy.wsdd by hand, which is not
really an option in a development env. when these tools are run 50 times a day ...

> java2wsdl --extraClasses does not add extraClasses option to deploy.wsdd
> ------------------------------------------------------------------------
>
>          Key: AXIS-1898
>          URL: http://issues.apache.org/jira/browse/AXIS-1898
>      Project: Axis
>         Type: Bug
>   Components: Deployment / Registries
>     Versions: 1.2RC3
>  Environment: Linux
>     Reporter: Tim Kagle

>
> When using --extraClasses as an argument to java2wsdl the statically generated WSDL is
correct, it includes all extra classes, but an option <parameter name="extraClasses" value="..."/>
is not added to the deploy.wsdd generated file. This is a problem because the automatically
generated WSDL file by the Axis runtime (by going to http://.../ServiceName?wsdl) is incorrect,
it's missing all the extra classes.
> Can this be fixed for the 1.2 release please?
> Thank you.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


Mime
View raw message