axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ". Ias" <iasan...@hotmail.com>
Subject Re: [Axis2] on NAMINGCLASSES or NamingClasses [ Re: [Axis2] WSDL Service Desc
Date Thu, 02 Dec 2004 21:04:05 GMT
Actually there are (unofficial) coding standards as alek said at 
http://www.ambysoft.com/javaCodingStandards.html. In section 1.3 at 
http://www.ambysoft.com/javaCodingStandards.pdf, 

7. Capitalize the first letter of standard acronyms . Names will often 
contain standard abbreviations, such
as SQL for Standard Query Language. Names such as sqlDatabase for an 
attribute, or SqlDatabase for a
class, are easier to read than sQLDatabase and SQLDatabase.

Personally I write code in that style (yes, we have (and even created too) 
many acronyms in web services :-)

Ias

>From: "Sanjiva Weerawarana" <sanjiva@opensource.lk>
>Reply-To: axis-dev@ws.apache.org
>To: <axis-dev@ws.apache.org>
>Subject: Re: [Axis2] on NAMINGCLASSES or NamingClasses [ Re: [Axis2] WSDL 
Service Desc
>Date: Fri, 3 Dec 2004 00:33:16 +0600
>
>-1 :-( ... I still prefer TypedXMLPullParser instead of
>TypedXmlPullParser for example.
>
>This is clearly something we all need to come to an agreement
>on. Shall we take a poll and see? Clearly nothing breaks
>either way!
>
>Sanjiva.
>
>----- Original Message -----
>From: "Aleksander Slominski" <aslom@cs.indiana.edu>
>To: <axis-dev@ws.apache.org>
>Sent: Thursday, December 02, 2004 10:51 PM
>Subject: [Axis2] on NAMINGCLASSES or NamingClasses [ Re: [Axis2] WSDL
>Service Desc
>
>
> > Chathura Herath wrote:
> >
> > >
> > > I have posted a proposal in the wiki for a possible Architecture for 
a
> > > WSDL Service Desc for Axis 2 based on the WSDL 2.0 Component Model.
> > >
> > > http://wiki.apache.org/ws/FrontPage_2fArchitecture_2fWSDL
> > >
> > little nitpick not that is about WOM but any class in Axis2:
> >
> > could we consider that AXIS, WSDL, XML, and especially SOAP are 
actually
> > used as words and not acronyms any longer?
> >
> > So we would have AxisWsdlService instead of AXISWSDLService etc.
> >
> > this is much easier (at least for me) to read ...
> >
> > thanks,
> >
> > alek
> >
> > --
> > The best way to predict the future is to invent it - Alan Kay
> >
>



Mime
View raw message