axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jayachandra Sekhara Rao Sunkara (JIRA)" <axis-...@ws.apache.org>
Subject [jira] Commented: (AXIS-1457) Something is wrong, wsdl???
Date Wed, 10 Nov 2004 08:42:33 GMT
     [ http://nagoya.apache.org/jira/browse/AXIS-1457?page=comments#action_55281 ]
     
Jayachandra Sekhara Rao Sunkara commented on AXIS-1457:
-------------------------------------------------------

Hi Henry!
I was able to reproduce the error on my end with doc/lit style. (Earlier it was tested for
default rpc/encoded style. sorry about that). On my side (I had written my own TestClient
to consume the deployed service) the soap message sent over the wire to consume the echoString_double
webservice looks like the following. Was it similar for you too?

POST /axis/services/1457Echo HTTP/1.0

Content-Type: text/xml; charset=utf-8

Accept: application/soap+xml, application/dime, multipart/related, text/*

User-Agent: Axis/1.2RC1

Host: localhost:7500

Cache-Control: no-cache

Pragma: no-cache

SOAPAction: ""

Content-Length: 405



<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
   <soapenv:Body>
      <echoString_double xsi:type="xsd:string" xmlns="http://tempuri.org/">10</echoString_double>
      <echoString_double xsi:type="xsd:string" xmlns="http://tempuri.org/">20</echoString_double>
   </soapenv:Body></soapenv:Envelope>

It appeared to me that this soap packet doesn't seem to be of document-literal structure.
Hence the second argument is being fed as null. I want to know whether your soap message also
looks the same way.

> Something is wrong, wsdl???
> ---------------------------
>
>          Key: AXIS-1457
>          URL: http://nagoya.apache.org/jira/browse/AXIS-1457
>      Project: Axis
>         Type: Bug
>     Versions: beta-2
>     Reporter: henry lu
>     Priority: Critical

>
> I use doc/literal to create a service:
> public interface Echo
> {
>     public String echoString(String arg);
>     public String echoString_double(String arg1, String arg2);
> }
> create wsdl file by:
>     <axis-java2wsdl
>       bindingname="${SERVICE_CLASS}"
>       output="${WSDL_FILE}" 
>       location="${HOST_URL}"
>       typemappingversion="1.2"
>       style="DOCUMENT"
>       use="LITERAL"
>       classname="${INT_CLASS}" 
>       namespace="${NAMESPACE_TAR}" 
>       soapaction="OPERATION"
>       >
>       <classpath refid="classpath_int.library" />
>     </axis-java2wsdl>
>   </target>
> create java files for both server and client by
>     <axis-wsdl2java
>       output="bind/."
>       deployscope="Session"
>       skeletondeploy="true"
>       url="bind/${WSDL_FILE}" 
>       verbose="true"
>       serverside="true"
>       typemappingversion="1.2"
>       >
>       <mapping
>         namespace="${NAMESPACE_TAR}" 
>         package="${PACKAGE}"
>       />
>       <classpath refid="classpath_bin.library" />
>     </axis-wsdl2java>
>   </target>
> and there is no deployment error.
> Here is my client code:
>   public String m_server_url;
>   public EchoService m_src;
>   public ClnEcho()
>   {
>      m_server_url = "http://localhost:8088/axis/services/Echo";
>      m_src = null;
>   }
>   public void do_call() throws Exception
>   {
>     System.out.println(m_server_url);
>     Echo srv_port = m_src.getEcho();
>       java.lang.String string_x1="10";
>       java.lang.String string_x2="20";
>       java.lang.String ret1 = srv_port.echoString(string_x1);
>       System.out.println("ret1="+ret1);
>       java.lang.String ret2 = srv_port.echoString_double(string_x1, string_x2);
>       System.out.println("ret2="+ret2);
>   }
> I got the foolowing results:
> c:\java_dev\axis\Echo>ant go
> Buildfile: build.xml
> go:
>      [java] log4j:WARN No appenders could be found for logger (org.apache.axis.i
> 18n.ProjectResourceBundle).
>      [java] log4j:WARN Please initialize the log4j system properly.
>      [java] http://localhost:8088/axis/services/Echo
>      [java] ret1=10
>      [java] ret2=10null
> But the correct anwser should be
> c:\java_dev\axis\Echo>ant go
> Buildfile: build.xml
> go:
>      [java] log4j:WARN No appenders could be found for logger (org.apache.axis.i
> 18n.ProjectResourceBundle).
>      [java] log4j:WARN Please initialize the log4j system properly.
>      [java] http://localhost:8088/axis/services/Echo
>      [java] ret1=10
>      [java] ret2=1020

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://nagoya.apache.org/jira/secure/Administrators.jspa
-
If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


Mime
View raw message