axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject [jira] Commented: (AXIS-1349) HTTPSender doesn't with proxies in 1.2beta
Date Tue, 05 Oct 2004 00:33:32 GMT
The following comment has been added to this issue:

     Author: Tom Jordahl
    Created: Mon, 4 Oct 2004 5:33 PM
I was looking at this and as far as I can see (without testing) the useSocket boolean is set
by the getSocket() call.  This call has moved
down in to the writeToSocket() line 382.  This is before the value is checked at line 398
(again in writeToSocket()).

Have you debugged this issue to verify that something was indeed broken by the code changes
from Axis 1.1 (or 1.2 Beta) to now?

I don't have a proxy I can test with...

View this comment:

View the issue:

Here is an overview of the issue:
        Key: AXIS-1349
    Summary: HTTPSender doesn't with proxies in 1.2beta
       Type: Bug

     Status: Unassigned
   Priority: Critical

    Project: Axis
             1.2 Beta

   Reporter: Michael Bock

    Created: Thu, 6 May 2004 6:25 AM
    Updated: Mon, 4 Oct 2004 5:33 PM
Environment: JDK 1.4.2

When using a proxy, the first line in HTTP requests should contain the complete url including
protocol and hostname. Since 1.2beta, the HTTPSender only sends the file component, so the
request isn't understood by the proxy. 
This problem doesn't arise with older version (up to 1.2alpha).
It seems to be caused by refactoring the getSocket-Call in HTTPSender.writeToSocket to another
location. So the parameter useFullURL is still false in 

        if (useFullURL.value) {
        } ....

As a workaround, the CommonsHTTPSender may be used, which doesn't suffer from this problem.

This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:

If you want more information on JIRA, or have a bug to report see:

View raw message