axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Loughran <ste...@apache.org>
Subject Re: AXIS with JDK 1.5
Date Thu, 16 Sep 2004 17:01:50 GMT
Nelson Minar wrote:

>>Axis developers, what do you think of this issue? Making Axis 1.2 compilable
>>by Tiger or put off the job to Axis 2 or any approach else?

> It sounds like the enum-as-keyword issue is simple enough to change,
> although is there a chance it will break code that relies on java2wsdl
> output? I don't understand the SAAJ / DOM 3 issue, but if it's not
> majorly difficult I think it'd be very valuable to make it compatible
> with both 1.4 and 1.5.

The biggest break is that anything that imports the enum package is 
hosed. This will affect internal code (say, 2 min in IntelliJ to fix), 
and the java2wsdl generation (testing). It also means that

1. anything that was build against an old version of axis and uses the 
classes in enum.* wont work.
2. any attempt to rebuild existing code that does so will need fixup to 
correct.

make no mistake, this will have to be flagged in the "stop, we have 
broken your code" part of the readme

-Steve

Mime
View raw message