axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject [jira] Commented: (AXIS-1580) Axis not JDK 1.5 compatible.
Date Thu, 30 Sep 2004 17:42:34 GMT
The following comment has been added to this issue:

     Author: Ias
    Created: Thu, 30 Sep 2004 10:42 AM
There are two main reasons for the problem:

1. enum keyword

2. DOM Level 3

I made some prototype to resolve that.
See for more details.

The remaining issue is when we are going to restructure Axis for Tiger? Axis 1.2, Axis 1.3,
or Axis 2?

Your opinions and comments are welcome.

P.S. I guess that Sun's SAAJ RI (source) is also incompilable with Tiger :-)
View this comment:

View the issue:

Here is an overview of the issue:
        Key: AXIS-1580
    Summary: Axis not JDK 1.5 compatible.
       Type: Bug

     Status: Unassigned
   Priority: Major

    Project: Axis
             1.2 Alpha

   Reporter: Matt Brown

    Created: Thu, 30 Sep 2004 10:03 AM
    Updated: Thu, 30 Sep 2004 10:42 AM
Environment: JDK 1.5.0, Windows XP SP2

Axis 1.1alpha includes a package named org.apache.axis.enum. In JDK 1.5, "enum" is a reserved

I tried to determine if this bug had already submitted. It didn't seem like it. Sorry if I
missed it.

This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:

If you want more information on JIRA, or have a bug to report see:

View raw message