axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nelson Minar <nel...@monkey.org>
Subject RE: WS-I testing: warnings about faultcode
Date Mon, 06 Sep 2004 23:31:47 GMT
>Well, strict adherence to standards is fine, but which standards?

Speaking as a user, it's clear that BP 1.1 is the target to hit this
month. SOAP 1.2 maybe some day.

>Strict adherence to SOAP 1.1 (or 1.2 for that matter) certainly
>allows, for instance, SOAP encoding, which is in conflict with strict
>adherence to WS-I BP.

I don't believe WS-I explicitly forbids a web services engine from
supporting SOAP encoding. It just doesn't address it - if you publish
a SOAP encoded service then WS-I isn't going to have anything to say
about how it should work, and that service isn't going to be WS-I
compliant. The underlying engine (Axis) may still be fully BP 1.1.

>While I agree with you about switches for every little thing, I do
>think a single "wsi.bp-compliance" flag might be a good idea, both
>for Axis 1.X and 2.0.

If you do go this route it should be the default behaviour,
particularly for clients. In my practical experience interop is worse
than it was three years ago. But WS-I seems to be the only way out of
the weeds.

Mime
View raw message