axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From j...@apache.org
Subject [jira] Updated: (AXIS-1277) WSDL2Java adds some unwanted characters in produced files
Date Thu, 01 Apr 2004 14:36:44 GMT
The following issue has been updated:

    Updater: Dario Di Minno (mailto:dariodiminno@yahoo.it)
       Date: Thu, 1 Apr 2004 6:35 AM
    Comment:
the schema imported in the wsdl
    Changes:
             Attachment changed to RMImport.xsd
    ---------------------------------------------------------------------
For a full history of the issue, see:

  http://issues.apache.org/jira/browse/AXIS-1277?page=history

---------------------------------------------------------------------
View the issue:
  http://issues.apache.org/jira/browse/AXIS-1277

Here is an overview of the issue:
---------------------------------------------------------------------
        Key: AXIS-1277
    Summary: WSDL2Java adds some unwanted characters in produced files
       Type: Bug

     Status: Unassigned
   Priority: Major

    Project: Axis
 Components: 
             WSDL processing
   Versions:
             1.1
             1.2 Beta

   Assignee: 
   Reporter: Dario Di Minno

    Created: Thu, 1 Apr 2004 6:30 AM
    Updated: Thu, 1 Apr 2004 6:35 AM
Environment: win2000, tomcat4.1, jdk1.4.2_02

Description:
WSDL2Java places some ">" characters in the produced files, that give problems at runtime,
so everytime I have to do a "clean up" of the files. 

Below I show you where I find these characters (in the use of QName(...) and in deploy.wsdd):

In ...BindingStub.java:
qName = new javax.xml.namespace.QName("...", ">importRequest");

In beans:
typeDesc.setXmlType(new javax.xml.namespace.QName("...", ">importRequest"));

In deploy.wsdd, in the parameter "type" of the element "parameter" in "operation":

<operation ...>
       <parameter qname="..." xmlns:pns="..." type="tns:>importRequest" xmlns:tns="..."
/>
       ...
</operation> 

These characters give problems at runtime, infact axis can't generate
the wsdl at the url http://...?wsdl

I get the following error instead:

AXIS error

Sorry, something seems to have gone wrong... here are the details:

Fault - makeTypeElement() was told to create a type
"{http://rmv3.abd.it/schemas/services/importservice}>importRequest", with no containing
element

AxisFault
 faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.generalException
 faultSubcode: 
 faultString: makeTypeElement() was told to create a type
"{http://rmv3.abd.it/schemas/services/importservice}>importRequest", with no containing
element
 faultActor: 
 faultNode: 
 faultDetail: 


Attached you find the wsdl file and an imported xsd schema.



---------------------------------------------------------------------
JIRA INFORMATION:
This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa

If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


Mime
View raw message