axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject [jira] Commented: (AXIS-824) SOAPAction Header not mapped to operation
Date Mon, 12 Apr 2004 14:57:43 GMT
The following comment has been added to this issue:

     Author: Tom Jordahl
    Created: Mon, 12 Apr 2004 7:56 AM
If you are adding a new option to the WSDD file (operationSeparator), *please* make sure to
update the documentation.
View this comment:

View the issue:

Here is an overview of the issue:
        Key: AXIS-824
    Summary: SOAPAction Header not mapped to operation
       Type: Bug

     Status: Open

    Project: Axis
             Basic Architecture

   Assignee: Jarek Gawor
   Reporter: Kevin Jones

    Created: Thu, 17 Apr 2003 10:16 AM
    Updated: Mon, 12 Apr 2004 7:56 AM
Environment: Operating System: Other
Platform: Other

I have a WSDL doc that adds a SOAPAction value (i.e. doesn't leave it blank). If
I run my client against

http://localhost/orinoco/services/Orinoco then it works

If I run it against


then I get the following

   <faultstring>The AXIS engine could not find a target service to invoke! 
targetService is urn:com.develop.ejws:orinoco#get

My wsdd is generated from the WSDL and I've also added the following entries

    <handler name="ActionHandler"
    <transport name="http">
            <handler type="ActionHandler"/>
            <handler type="URLMapper"/>
            <handler type="java:org.apache.axis.handlers.http.HTTPAuthHandler"/>

I've tried with both an RC2 generated client and a command line utility that I
have. both set the SOAPAction header (I can see the trace in tcpmon) but I
always get the same fault.

This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:

If you want more information on JIRA, or have a bug to report see:

View raw message