axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject [jira] Updated: (AXIS-824) SOAPAction Header not mapped to operation
Date Wed, 24 Mar 2004 22:51:58 GMT
The following issue has been updated:

    Updater: gawor (
       Date: Wed, 24 Mar 2004 2:51 PM
Here's another one that defaults to '#' as an operation separator.
             Attachment changed to actionhandler2.patch
For a full history of the issue, see:

View the issue:

Here is an overview of the issue:
        Key: AXIS-824
    Summary: SOAPAction Header not mapped to operation
       Type: Bug

     Status: Open

    Project: Axis
             Basic Architecture

   Assignee: Axis Developers Mailing List
   Reporter: Kevin Jones

    Created: Thu, 17 Apr 2003 10:16 AM
    Updated: Wed, 24 Mar 2004 2:51 PM
Environment: Operating System: Other
Platform: Other

I have a WSDL doc that adds a SOAPAction value (i.e. doesn't leave it blank). If
I run my client against

http://localhost/orinoco/services/Orinoco then it works

If I run it against


then I get the following

   <faultstring>The AXIS engine could not find a target service to invoke! 
targetService is urn:com.develop.ejws:orinoco#get

My wsdd is generated from the WSDL and I've also added the following entries

    <handler name="ActionHandler"
    <transport name="http">
            <handler type="ActionHandler"/>
            <handler type="URLMapper"/>
            <handler type="java:org.apache.axis.handlers.http.HTTPAuthHandler"/>

I've tried with both an RC2 generated client and a command line utility that I
have. both set the SOAPAction header (I can see the trace in tcpmon) but I
always get the same fault.

This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:

If you want more information on JIRA, or have a bug to report see:

View raw message