axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Srinath Perera" <hemap...@opensource.lk>
Subject Null pointer in the axis Java2WSDL
Date Tue, 10 Feb 2004 07:17:29 GMT
Hi All;

In the Current Head in the Axis I am getting a null pointer exception
for the Java2WSDL, I check with axis1.2 alpha and it is working there
fine.
java.lang.NullPointerException
	at org.apache.axis.wsdl.fromJava.Types.getTypeQName(Types.java:688)
	at org.apache.axis.wsdl.fromJava.Types.getTypeQName(Types.java:702)
	at org.apache.axis.wsdl.fromJava.Types.writeTypeForPart(Types.java:420)
	at
org.apache.axis.wsdl.fromJava.Emitter.writePartToMessage(Emitter.java:1854)
	at
org.apache.axis.wsdl.fromJava.Emitter.writeRequestMessage(Emitter.java:1447)
	at org.apache.axis.wsdl.fromJava.Emitter.writeMessages(Emitter.java:1095)
	at org.apache.axis.wsdl.fromJava.Emitter.writePortType(Emitter.java:1066)
	at org.apache.axis.wsdl.fromJava.Emitter.getWSDL(Emitter.java:499)
	at org.apache.axis.wsdl.fromJava.Emitter.emit(Emitter.java:350)
	at org.apache.axis.wsdl.fromJava.Emitter.emit(Emitter.java:445)
	at org.apache.axis.wsdl.Java2WSDL.run(Java2WSDL.java:622)
	at org.apache.axis.wsdl.Java2WSDL.main(Java2WSDL.java:668)

this is the command I used

org.apache.axis.wsdl.Java2WSDL
-otemp.wsdl -l"http://localhost:8080/axis/services/WidgetPrice" 
heavytest.performence.HeavyTest

I am trying to fix it, But want to confirm it is a bug.
If anybody knows something about it give me a hand

Srinath



Mime
View raw message