axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 25485] New: - Method returning Vector is mapped to ns2:Vector instead of soapenc:Array
Date Fri, 12 Dec 2003 17:55:14 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=25485>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=25485

Method returning Vector is mapped to ns2:Vector instead of soapenc:Array

           Summary: Method returning Vector is mapped to ns2:Vector instead
                    of soapenc:Array
           Product: Axis
           Version: 1.1
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Serialization/Deserialization
        AssignedTo: axis-dev@ws.apache.org
        ReportedBy: adrianpj@users.sourceforge.net


I'm using EJBProvider to publish interface methods of a Stateless Session Bean.
 One of them is declared to return a java.util.Collection, and a
java.util.Vector (that implements java.util.Collection) is in reality returned.

Axis will map that type (automatically, not forced in any wsdd typeMapping) to a
ns2:Vector instead of a soapenc:Array that will be more interoperable.

This is an extract of the soappenv body:

<multiRef id="id0" soapenc:root="0"
soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
xsi:type="ns2:Vector" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:ns2="http://xml.apache.org/xml-soap">........[snip].......

I have changed the implementation of my method, from using a java.lang.Vector to
a java.lang.ArrayList and now it retuns a soapenc:Array.

<multiRef id="id0" soapenc:root="0"
soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
xsi:type="soapenc:Array" soapenc:arrayType="ns2:anyType[4]"
xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:ns2="http://www.w3.org/2001/XMLSchema">.....[snip]......

Dims told me at #apache-axis@irc.freenode.net that it's a backwards
compatability thing to support apache soap interop, and that I could open a
bugzilla bug asking for an enhancement to clean it up.  Here it is ;)

Mime
View raw message