axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Klas Skogmar <klas.skog...@exallon.sigma.se>
Subject url property in wsdl2java ant task
Date Wed, 15 Oct 2003 13:06:22 GMT
Hi.
It seems I get the wrong path when I use the wsdl2java-ant task when I
specify a local file using relative reference from the basedir specified in
the build.xml.

See the output of the ant-task:

generate-axis-client:
[axis-wsdl2java] WSDL2Java ./config/axistest.wsdl
Parsing XML file:  ./config/axistest.wsdl
[axis-wsdl2java] Running Wsdl2javaAntTask with parameters:
[axis-wsdl2java] 	verbose:true
[axis-wsdl2java] 	debug:false
[axis-wsdl2java] 	server-side:false
[axis-wsdl2java] 	skeletonDeploy:false
[axis-wsdl2java] 	helperGen:false
[axis-wsdl2java] 	factory:null
[axis-wsdl2java] 	testCase:true
[axis-wsdl2java] 	noImports:false
[axis-wsdl2java] 	NStoPkg:{*=generatedpackage}
[axis-wsdl2java] 	output:C:\eclipse\workspace\AxisClient\src
[axis-wsdl2java] 	deployScope:
[axis-wsdl2java] 	URL:./config/axistest.wsdl
[axis-wsdl2java] 	all:true

See how the output directory is correct? Ok, here is the stack trace:

[axis-wsdl2java] java.io.FileNotFoundException:
C:\eclipse\.\config\axistest.wsdl (The system cannot find the path
specified)
[axis-wsdl2java] 	at java.io.FileInputStream.open(Native Method)
[axis-wsdl2java] 	at
java.io.FileInputStream.<init>(FileInputStream.java:103)
[axis-wsdl2java] 	at
java.io.FileInputStream.<init>(FileInputStream.java:66)
[axis-wsdl2java] 	at
sun.net.www.protocol.file.FileURLConnection.connect(FileURLConnection.java:6
9)
[axis-wsdl2java] 	at
sun.net.www.protocol.file.FileURLConnection.getInputStream(FileURLConnection
.java:148)
[axis-wsdl2java] 	at java.net.URL.openStream(URL.java:955)
[axis-wsdl2java] 	at
org.apache.crimson.parser.InputEntity.init(InputEntity.java:209)
[axis-wsdl2java] 	at
org.apache.crimson.parser.Parser2.parseInternal(Parser2.java:471)
[axis-wsdl2java] 	at
org.apache.crimson.parser.Parser2.parse(Parser2.java:305)
[axis-wsdl2java] 	at
org.apache.crimson.parser.XMLReaderImpl.parse(XMLReaderImpl.java:442)
[axis-wsdl2java] 	at
org.apache.crimson.jaxp.DocumentBuilderImpl.parse(DocumentBuilderImpl.java:1
85)
[axis-wsdl2java] 	at
org.apache.axis.utils.XMLUtils.newDocument(XMLUtils.java:322)
[axis-wsdl2java] 	at
org.apache.axis.utils.XMLUtils.newDocument(XMLUtils.java:367)
[axis-wsdl2java] 	at
org.apache.axis.wsdl.symbolTable.SymbolTable.populate(SymbolTable.java:384)
[axis-wsdl2java] 	at
org.apache.axis.wsdl.gen.Parser$WSDLRunnable.run(Parser.java:245)
[axis-wsdl2java] 	at java.lang.Thread.run(Thread.java:536)
[axis-wsdl2java] BUILD FAILED:
file:C:/eclipse/workspace/AxisClient/build.xml:24: Error while processing
WSDL in Wsdl2javaAntTask for ./config/axistest.wsdl

Is this an unknown bug? 

/Klas

Mime
View raw message